"+1 other download" message is pointless

RESOLVED DUPLICATE of bug 820537

Status

()

Firefox
Downloads Panel
--
minor
RESOLVED DUPLICATE of bug 820537
5 years ago
5 years ago

People

(Reporter: gcp, Unassigned)

Tracking

Trunk
All
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 708985 [details]
Image of situation

When doing 4 simultaneous downloads, the filename of the last download is replaced by the "+1 other download" message, probably because the intention is to let the user "expand" the download manager into the download view in the library, when he has *many* downloads ongoing.

However if you look at the attached image, in the "+1 other" situation the message is entirely pointless: if it *wouldn't* be overlayed on the filename, the user would have a full view on all downloading files, and no need nor desire to expand the download manager. So in this case the message is pointless, in fact it makes itself necessary because it's sitting on top of useful information that should be displayed instead.
The problem is that even if you add another download in the +1 case, we always have to add the Show All Downloads entry, and then we have a menu that shows either 3+1 or 4+1 items in non-well understandable situations (for the common user). So in the end it's added code complication for a small benefit, could be better to add telemetry to figure what's the most common number of concurrent downloads and increase the default size to that.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 820537
You need to log in before you can comment on or make changes to this bug.