Closed Bug 837070 Opened 7 years ago Closed 4 years ago

IonMonkey: IonMacroAssembler.h contains a lot of function bodies

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 996602

People

(Reporter: h4writer, Unassigned)

References

(Blocks 1 open bug)

Details

Don't know if this is a rule or just something that is considered best practice, but in all our files we try to put large function bodies in the .cpp file, making the .h a bit cleaner.

IonMacroAssembler.h is full of function bodies and they should get moved to IonMacroAssembler.cpp
Blocks: 996602
Assignee: general → nobody
I will close this bug for now, as this is a task which is too hard to do at once, and which is included in the work being done to address Bug 996602.

The new style for writing the MacroAssembler implies that method body would either be moved to the .cpp file or to the -inl.h file.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 996602
You need to log in before you can comment on or make changes to this bug.