Delegate calendars are not synced

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Calendar
RESOLVED WONTFIX
6 years ago
5 months ago

People

(Reporter: Maël Lavault, Unassigned)

Tracking

({feature})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Hi,

When I add my google account to calendar app, my calendar won't sync. 

My calendar is remotely synchronized from an ics file on a private server on my Google Agenda. This works well on Andoid, WebOS and Google Agenda website, but not in FirefoxOS.

Thanks.
Maybe James knows more about this situation. James?
Flags: needinfo?(jlal)
I am not 100% sure how this sync between your private server and Google but I know we don't directly support importing ICS files. We only support ical data them over CalDAV.

I would love to help you but I need some more details.

My own calendar syncs without issue though we recently had an issue with empty calendars that we fixed...
Flags: needinfo?(jlal)

Updated

6 years ago
Flags: needinfo?(mael.lavault)
(Reporter)

Comment 3

6 years ago
So when you go on Google Calendar, on the left side you have a list of your calendar. The first part is called "your calendar", the second is called "other calendar" (translation are approximative since my interface is in french). 

Aside the "other calendar" title is a little arrow. Click on it and select add by url. Here you can specify a custom adress which serves an .ics file.

FirefoxOS don't have to support ics directly, it should appear like any other google calendar ;)
Flags: needinfo?(mael.lavault)
Ahhh! Ok this sounds like a delegate calendar (someone else owns the calendar technically) which we don't support quite yet. It is part of CalDAV but an extension.

We have plans to implement this functionality but not quite yet.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Remote google calaendar won't sync → Delegate calendars are not synced
(Reporter)

Comment 5

6 years ago
Ok nice, thanks for looking at it !

Updated

5 years ago
Keywords: feature

Comment 6

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.