Closed Bug 837132 Opened 9 years ago Closed 8 years ago

The 'Remove' action should make thumbnails never show up on about:home again... evar

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox21 affected, firefox22 affected, fennec21+)

RESOLVED FIXED
Firefox 23
Tracking Status
firefox21 --- affected
firefox22 --- affected
fennec 21+ ---

People

(Reporter: aaronmt, Assigned: wesj)

Details

Attachments

(1 file)

Currently, when one removes "Firefox: Support" and "Firefox: Customize with add-ons", they get re-inserted into the top-site thumbnails on about:home the next time about:home is loaded.

Steps to reproduce:

i) Long-tap and remove "Firefox: Support" and "Firefox: Customize with add-ons"
ii) On the AwesomeScreen, tap "Firefox: About Your Browser"
iii) Tap the back button to go back to about:home

--
Nightly (02/01)
Samsung Galaxy Nexus (Android 4.2)
Version: Firefox 19 → Trunk
I'm guessing it's because of they are the only two top-sites and they are added when loadTopSitesThumbnails() is called? Shouldn't the choice to remove them "stick"?
(In reply to Aaron Train [:aaronmt] from comment #1)
> I'm guessing it's because of they are the only two top-sites and they are
> added when loadTopSitesThumbnails() is called? Shouldn't the choice to
> remove them "stick"?

Not currently. We only remove them from the History DB. When you visit the site, it is put back in History and will show up on about:home.
They are also bookmarks, which gives them power to re-appear in "top sites" queries.
What behavior do we want here?
Flags: needinfo?(ibarlow)
tracking-fennec: ? → 21+
ping?
Updated the bug title to reflect the intent of this bug. If we do this, do we need a UI to "Unremove"/"Unbanish" pages from the top sites?
Summary: "Firefox: Support" and "Firefox: Customize with add-ons" automatically re-insert into top-site thumbnails on about:home → The 'Remove' action should make thumbnails never show up on about:home again... evar
(In reply to Mark Finkle (:mfinkle) from comment #6)
> Updated the bug title to reflect the intent of this bug. If we do this, do
> we need a UI to "Unremove"/"Unbanish" pages from the top sites?

I think we do. Desktop shows "Undo" and "Restore All" links after getting rid of a new tab thumbnail. Maybe this is a job for... super toast!
Ian - This will change when we make the new About:Home design. In the short term, should we just remove "Remove" on Aurora and Beta?
That sounds reasonable.
Flags: needinfo?(ibarlow)
Wes - Can we get a simple backout out patch for Aurora and Beta. I'd be fine with just remving the menu itself and leaving the code.
Assignee: nobody → wjohnston
Heck, might as well back out for Fx23 too.
need info for the backout patch
Flags: needinfo?(wjohnston)
Attached patch Patch v1Splinter Review
Removes the "Remove" option entirely.
Attachment #737721 - Flags: review?(margaret.leibovic)
Flags: needinfo?(wjohnston)
Comment on attachment 737721 [details] [diff] [review]
Patch v1

Let's make sure there's a follow up bug on file to fix this the right way.

I was going to remind you to remove the strings that go along with this, but if we can make a fix quickly that we want to uplift, I suppose it's better to reduce the string churn. (Also, I remember there was a post recently about how uplifting string removals also causes churn.)
Attachment #737721 - Flags: review?(margaret.leibovic) → review+
(In reply to :Margaret Leibovic from comment #14)
> Comment on attachment 737721 [details] [diff] [review]
> Patch v1
> 
> Let's make sure there's a follow up bug on file to fix this the right way.

The new about:home screen only shows "bookmarked" sites in the "Top Sites" thumbnails. This means we don't need any Remove action in the future. The Remove action was supposed to remove "visited" sites from the thumbnails because the sites might be of a private nature, or you just don't want the site shown.

If thumbnails are only bookmarks, the user has much more control over what is shown and what is not, without needing a "never show this on thumbnails" feature.
(In reply to Mark Finkle (:mfinkle) from comment #15)
> (In reply to :Margaret Leibovic from comment #14)
> > Comment on attachment 737721 [details] [diff] [review]
> > Patch v1
> > 
> > Let's make sure there's a follow up bug on file to fix this the right way.
> 
> The new about:home screen only shows "bookmarked" sites in the "Top Sites"
> thumbnails. This means we don't need any Remove action in the future. The
> Remove action was supposed to remove "visited" sites from the thumbnails
> because the sites might be of a private nature, or you just don't want the
> site shown.
> 
> If thumbnails are only bookmarks, the user has much more control over what
> is shown and what is not, without needing a "never show this on thumbnails"
> feature.

Sounds good to me. Wes, kill the string when you land this!
https://hg.mozilla.org/mozilla-central/rev/aa3760831c60
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Verified fixed on:
Build: Firefox for Android 23.0a1( 2013-04-21)
Device: LG Nexus 4
OS: Android 4.2.2
Status of follow-ups mentioned?
(In reply to Aaron Train [:aaronmt] from comment #20)
> Status of follow-ups mentioned?

As I mention in comment 10, the new behavior will be part of the design for the new Home page. We won't need an explicit bug for this feature. It's part of how the new Home page will work.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.