puppetize.sh should specify the puppet version

RESOLVED FIXED

Status

Infrastructure & Operations
RelOps
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: dustin, Assigned: dustin)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
I mirrored the puppetlabs repo, bringing it up to 3.0.2.  This doesn't cause problems for running systems, but when puppetizing a new host, puppetize.sh just runs
  yum install puppet
which gets 3.0.2, which doesn't work with the current masters.
(Assignee)

Comment 1

5 years ago
Sorry, this is in the kickstart scripts, not puppetize.sh.
(Assignee)

Comment 2

5 years ago
Created attachment 709108 [details] [diff] [review]
bug837186.patch
Attachment #709108 - Flags: review?(rail)
(Assignee)

Comment 3

5 years ago
Fixed in the kickstart scripts on the PXE servers (well, committed to puppet - it will be fixed in an hour or so)
Comment on attachment 709108 [details] [diff] [review]
bug837186.patch

lgtm
Attachment #709108 - Flags: review?(rail) → review+
(Assignee)

Comment 5

5 years ago
landed - thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.