High CPU in FF 18 in some web pages

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Carlos Velasco, Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

Accesing some web pages cause Firefox 18 to use up to 80% CPU (in 1 CPU system).
This doesn't happen when using Firefox 17.

Example web page:
http://www.fisiovivax.com

Seems related to new JavaScript changes in FF 18.



Actual results:

High CPU usage


Expected results:

Normal CPU usage
(Reporter)

Comment 1

5 years ago
Tested using Safe mode... no changes.
>Tested using Safe mode... no changes.
Then it's not caused by the JS changed because the JS jit is disabled in the safemode.

I suspect the image quality downscaler on the given site.
There is a big image in the middle that changes with an effect and after the image got replaced by a new one the image shrinks (looks ugly !)
Component: Untriaged → ImageLib
Product: Firefox → Core
(Reporter)

Comment 3

5 years ago
Not sure about problem in the effect and shrink.
In same site, I see also high CPU problem with this page:
http://www.fisiovivax.com/fisioterapia.html

No effect here, maybe shrink, but this is static...
Please only one issue in one bug report or the bug will become invalid
(Reporter)

Comment 5

5 years ago
I *think* it is the same issue
Sorry, you are right because it's the same site.

for http://www.fisiovivax.com/fisioterapia.html:
I see 25% (=100% of one Core) used CPU on my system with Firefox15 and 15% with Firefox18.0.1
The same page is using 15% with Opera12 and 20% with Safari on a different system

That looks like a bug in the page, marking invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: ImageLib → General
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.