If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Settings] Date & Time: the 29th is showing up as 01 in the drop down menu when changing the date

VERIFIED DUPLICATE of bug 835902

Status

Firefox OS
Gaia::Settings
VERIFIED DUPLICATE of bug 835902
5 years ago
5 years ago

People

(Reporter: nkot, Assigned: rudyl)

Tracking

({smoketest})

unspecified
ARM
Gonk (Firefox OS)
smoketest

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 709219 [details]
screenshot

Description: The 29th day is showing up as 01 in the drop down menu when user changing the date in the settings (or in the Calendar app, when setting up date for a new event)


Repro Steps:
1. Load the Unagi build 2013-02-01-070203
2. Open the Settings app
3. Select "Date & Time" under the "Personalization" section
4. Turn off "Set Automatically"
5. Tap on Date

Actual Results:
*The 29th day is shown as 01 for every month

Expected Results:
*All days from range 1-30(31) are shown for each month

*similar to bug #835902

Repro frequency:
*100%

Notes:
Kernel: Dec 5 (date only!)
Gecko: 51daa19d4045669303b77807d5832568e2d1f686
Gaia: 4d1087307c7377b1d4c7d72ba2e90e63cdb8fbc4

*Screenshot attached
(Reporter)

Updated

5 years ago
Summary: [B2G][Settings] Date & Time: the 29th is showing up as 01 in the drop down menu when changing the date (except the month of February) → [B2G][Settings] Date & Time: the 29th is showing up as 01 in the drop down menu when changing the date

Updated

5 years ago
blocking-b2g: --- → tef?
(Reporter)

Updated

5 years ago
Keywords: unagi
Still reproducible in the Calendar app.

Unagi version: 20130204070201
Gecko: 2aa2cbcc4e4bc667770eaeaad9c36efeadc1674a
Gaia: b277f372f097c77dd2ec1988a80e458280dda491
Kernal: Dec 5
Assignee: nobody → rlu
Fixed in Bug 835902 with the following commit merged to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/82b47138452f636f937d40e8167c93f9336da773
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
blocking-b2g: tef? → -
Resolution: FIXED → DUPLICATE
Duplicate of bug: 835902
Still repros in build 20130205070201
Kernal: Dec 5
Gaia: 9f5a4a9f6d321dbb4805f1f98623e770b0e89698
Gecko: a63eb9592fab5ccd3a3ad87767b3117f328710df

Comment 5

5 years ago
Verified as a Duplicate of 835902
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.