Last Comment Bug 837278 - Support selecting tests to run in in-tree mach and Makefile test commands
: Support selecting tests to run in in-tree mach and Makefile test commands
Status: RESOLVED FIXED
[mach]
:
Product: Add-on SDK
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86_64 Windows 8
: P3 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 869354 909992 (view as bug list)
Depends on: sdk-mochitestification-fx
Blocks: sdk-test-issues
  Show dependency treegraph
 
Reported: 2013-02-01 13:49 PST by Dave Townsend [:mossop]
Modified: 2015-02-20 13:00 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Add ability to filter tests to mach jetpack-test (2.36 KB, patch)
2013-04-06 21:32 PDT, Wes Kocher (:KWierso)
dtownsend: feedback+
Details | Diff | Splinter Review

Description Dave Townsend [:mossop] 2013-02-01 13:49:00 PST
Bug 793928 added a way to run the jetpack tests from mach and make but it just runs all the tests. It would be good to add a way to select an individual test
Comment 1 Wes Kocher (:KWierso) 2013-04-06 21:32:49 PDT
Created attachment 734317 [details] [diff] [review]
Add ability to filter tests to mach jetpack-test

So, this seems to let me filter tests when using | mach jetpack-test |. (Or at least, | mach jetpack-test -f context | only runs the contextMenu tests, and | mach jetpack-test -f context:testUnload | only runs the contextMenu tests that include "testUnload" in the test name.)

It isn't working for me with make, though.
Comment 2 Dave Townsend [:mossop] 2013-04-15 14:34:11 PDT
Comment on attachment 734317 [details] [diff] [review]
Add ability to filter tests to mach jetpack-test

Review of attachment 734317 [details] [diff] [review]:
-----------------------------------------------------------------

I don't especially like the regexp filter method of selecting tests and would really like us to just pass the path to a test file to run, but I think that needs cfx changes and pain so I guess this is good for the interim.

gps should review this really but it looks fine for me. Mach just calls make so not sure why make isn't working. How are you running it, with something like |EXTRA_TEST_ARGS="-f context" make jetpack-tests| ?
Comment 3 Wes Kocher (:KWierso) 2013-05-07 01:49:45 PDT
*** Bug 869354 has been marked as a duplicate of this bug. ***
Comment 4 Wes Kocher (:KWierso) 2013-08-27 22:15:24 PDT
*** Bug 909992 has been marked as a duplicate of this bug. ***
Comment 5 Dave Townsend [:mossop] 2015-02-20 13:00:36 PST
Fixed by bug 1035512

Note You need to log in before you can comment on or make changes to this bug.