If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Page title "[object Object]" when reloading after network error

VERIFIED FIXED in Firefox 21

Status

Firefox OS
Gaia::Browser
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: cjones, Assigned: fabrice)

Tracking

({regression})

unspecified
B2G C4 (2jan on)
x86_64
Linux
regression
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 verified, b2g18-v1.0.0 fixed)

Details

Attachments

(1 attachment)

STR
 (1) Try to load a page
 (2) Page load interrupted by network error
 (3) Reload page

I see the title "[object Object]" in the title bar.

b? -> radar

Comment 1

5 years ago
Another way to replicate this is:

1. Open fresh browser instance
2. Tap > to open tab browser
3. Tap < to close tab browser
This looks related to bug 837267 and is a recent regression.

I can reproduce on Otoro with a 2013-02-05 nightly, but not a Unagi with 2013-01-30.
Keywords: regression, regressionwindow-wanted
Fabrice, do you think this will be fixed by bug 837317 ?
(Assignee)

Comment 4

5 years ago
(In reply to Ben Francis [:benfrancis] from comment #3)
> Fabrice, do you think this will be fixed by bug 837317 ?

Unfortunately not. I'm still chasing this one. Do you know where you get the string you display there? A very easy way to reproduce is :
- open the browser app.
- got to the tab view, don't do anything
- go back to the "home" page
(Assignee)

Comment 5

5 years ago
Created attachment 710384 [details] [diff] [review]
patch
Assignee: nobody → fabrice
Attachment #710384 - Flags: feedback?(ben)
blocking-b2g: tef? → tef+
(Assignee)

Updated

5 years ago
Attachment #710384 - Flags: feedback?(ben) → review?(dale)
Attachment #710384 - Flags: review?(dale) → review+
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5e3ea3993b68

Comment 7

5 years ago
https://hg.mozilla.org/mozilla-central/rev/5e3ea3993b68
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-b2g18/rev/e0f034994ffa
https://hg.mozilla.org/releases/mozilla-b2g18_v1_0_0/rev/688536316faa
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → fixed
status-firefox19: --- → wontfix
status-firefox20: --- → wontfix
status-firefox21: --- → fixed
Keywords: regressionwindow-wanted
Target Milestone: --- → B2G C4 (2jan on)

Comment 9

5 years ago
Build ID:20130219070200
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/98354c0298ab
Gaia   edaca00b1eb7534120b6255db5d5200fb1d86d65
Kernel: Dec 5

I am not able to reproduce it on "Unagi" device

Comment 10

5 years ago
Does not make sense to create a regression issue.
Flags: in-moztrap-

Comment 11

5 years ago
This issue no longer reproduces on Unagi device:
Build ID: Build ID: 20130401070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/f9f11b8cbf8a
Gaia: 663101b6eb809383e5882d9bc3868a923a57998a

Page title does not change to "[object Object]" when reloading the page after network error.
Verified fixed
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.