Once an HTML page has been visited, returning to that page fails to find anchor

RESOLVED WORKSFORME

Status

()

Core
HTML: Parser
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Mark, Unassigned)

Tracking

18 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

233.94 KB, text/plain
Details
(Reporter)

Description

5 years ago
Created attachment 709303 [details]
a.htm

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

I visit a page from another page and the anchor is found.


Actual results:

If I reopen a visited page after having once visited it using an anchor, I am taken to the top of the that page, not to the anchor. I suspect that because the page has been cached, the browser simply brings up the page and ignores the anchor 


Expected results:

Each time I visit a page, I should be taken to the requested anchor on the page, even if I have visited that page before. For example: Actors - Ježek, Jaroslav. 1906-1942 [Jezek, Jaroslav] (see Musicians - Ježek, Jaroslav. 1906-1942.) takes me to the correct anchor the first time, but if I return to the calling page, the second time I click on the link I am taken to the top of the page. Calling page attached; I did not see a way to attach more than one file. The called page is: www.czechout.org/m.htm.

The call is:
     <a class="ref" href="m.htm#A651-10">Musicians - Ježek, Jaroslav. 
The anchor is:
    <a name="A651-10">- Ježek, Jaroslav. 1906-1942</a>
Hope this helps - you have a fine product!
Mark

Comment 1

5 years ago
http://www.czechout.org/a.htm

Confirmed with Firefox 19 Beta, but works with Nightly 2013-02-04-03-09-41-mozilla-central-firefox-21.0a1.ru.linux-x86_64

Comment 2

5 years ago
WFM 2013-02-04-04-20-19-mozilla-aurora-firefox-20.0a2.en-US.linux-x86_64
WFM 2012-11-13-03-06-58-mozilla-central-firefox-19.0a1.en-US.linux-x86_64
WFM 2012-11-18-03-07-13-mozilla-central-firefox-19.0a1.en-US.linux-x86_64
WFM 2012-12-17-03-08-50-mozilla-central-firefox-20.0a1.de.linux-x86_64

Comment 3

5 years ago
(but there are a few fixed bugs concerning overflow: hidden, e.g. bug 811301)
Mark could you verify if you still have that problem?
Flags: needinfo?(mark)
(Reporter)

Comment 5

5 years ago
(In reply to Tiziana Sellitto [:tiziana] from comment #4)
> Mark could you verify if you still have that problem?

Yes. I checked it again today. The same problem exists. I answered this several days ago, but for some reason my answer is not here. Sorry. I am traveling, so difficult to get on regularly.
Flags: needinfo?(mark)

Comment 6

2 years ago
User Agent 	Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Version 	46.0a1
Build ID 	20160112030207
Channel 	nightly

Thank you for taking time to report this.
Are you still able to reproduce this in the latest version ? I cannot reproduce in the current version.
Component: Untriaged → HTML: Parser
Flags: needinfo?(mark)
Product: Firefox → Core

Comment 7

2 years ago
It is not reproducible. Closing this as works for me.
Please feel free to reopen this bug if it still reproduces in the latest versions. Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Flags: needinfo?(mark)
You need to log in before you can comment on or make changes to this bug.