All users were logged out of Bugzilla on October 13th, 2018

MOZ_CHROME_FILE_FORMAT=jar does not output jar files to dist/bin/chrome

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
8 months ago

People

(Reporter: BinOC, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 709324 [details]
Comparison screenshot of current comm-release and comm-central in dist/bin/chrome

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0 SeaMonkey/2.15
Build ID: 20130201160628

Steps to reproduce:

Specified MOZ_CHROME_FILE_FORMAT=jar in confvars.sh or --enable-chrome-format=jar in .mozconfig using current 2013/02/01 comm-central trunk


Actual results:

The build system deposits flat files and folders for chrome files in dist/bin/chrome


Expected results:

The build system should deposit separate jar in dist/bin/chrome as it does in current comm-release branch
(Reporter)

Updated

6 years ago
Version: SeaMonkey 2.15 Branch → Trunk
(Reporter)

Updated

6 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
(Reporter)

Updated

6 years ago
Component: Build Config → Build Config
Product: SeaMonkey → Core
(Reporter)

Comment 1

6 years ago
Ok, this has upon further testing has proved not to be isolated to comm-central it is a flaw in the entire build system encompassing mozilla-central. Most likely by design.
It is by design. You get jars when you "make package".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

6 years ago
I suppose it is a good thing I worked out an alternative (read: co-op) in case making a package or install fails. Which it does for me in comm-central and I am not sure why.

The work around if you are in that particular situation is to call the portion of the packaging system that does the processing. 

As far as I know (but don't quote me on that) this can only apply to comm-central and only if you are wanting the older multi-jar files and are unable or unwilling to use the built in make install/package commands.

cd to your objdir and run these two commands:

echo >blank.txt

./_virtualenv/Scripts/python.exe ../mozilla/toolkit/mozapps/installer/packager.py -DBINPATH=bin --format jar --removals ./blank.txt --ignore-errors --jarlogs ./ --optimizejars ./mozilla/dist ./mozilla/dist/jar-processed

That should process it and deposit them objdr/mozilla/dist/jar-processed/. There may be a bit of clean up to do.

There will be no more responses from me on this bug, but I felt it was valuable if someone ends up in the same situation as I was.

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.