Use better default thumbnails on about:home when we don't have a screenshot

RESOLVED DUPLICATE of bug 885519

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 885519
5 years ago
4 years ago

People

(Reporter: mfinkle, Assigned: Margaret)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ui-hackathon)

Attachments

(2 attachments)

We currently use an empty thumbnail with a Firefox logo watermark in situations where we do not have a real screenshot for the thumbnail.

We could be a little more creative if we have a favicon for site:
* Find the dominant color of the favicon and use it as the background of the thumbnail.
* Put the favicon in the thumbnail somewhere. Maybe centered? Maybe in the top/Left?
(Reporter)

Updated

5 years ago
Summary: Create and use better default thumbnails on about:home when we don't have a screenshot → Use better default thumbnails on about:home when we don't have a screenshot
(Assignee)

Comment 1

5 years ago
Ian, did you mention at one point that desktop was thinking about something similar for the new tab page? Do you guys have any mockups of how to make this look good? I wouldn't mind playing around with this :)
OS: Mac OS X → Android
Hardware: x86 → ARM
Created attachment 739171 [details]
Mockup

I was actually just playing with this as part of our new about:home redesign, and came up with something that might be nice. 

* Thumbnail centers the favicon in a 32dp x 32dp space
* Thumbnail background samples the dominant colour and dials it down to 15% opacity
* 1 dp border (new) uses the same dominant colour, at 50% opacity

Updated

5 years ago
Blocks: 862793
Created attachment 739753 [details]
favicons with colours

We should also apply this same colour logic to small favicons in our new about:home lists.
(Assignee)

Updated

5 years ago
Whiteboard: ui-hackathon
(Assignee)

Updated

5 years ago
Assignee: nobody → margaret.leibovic
Depends on: 839855
(Assignee)

Comment 4

4 years ago
This was fixed by bug 885519.
No longer blocks: 862793
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 885519
You need to log in before you can comment on or make changes to this bug.