Closed Bug 837439 Opened 8 years ago Closed 8 years ago

Clobber when /CLOBBER file is different than the one in the objdir

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 837323

People

(Reporter: philor, Unassigned)

References

Details

I suspect this isn't [simple], but we need to do it anyway.

When the CLOBBER file in the root of the srcdir is newer than the one in the objdir, configure fails out with an error saying that you have to clobber. The problem for buildslaves is that what just happened to inbound isn't particularly rare or difficult to arrange:

* clobber set with the clobberer at 15:00:59
* CLOBBER file touched at 15:03:24
* build started, doing the clobberer-forced clobber, on the cset before the one that touched CLOBBER, at 15:05:02
* build started 18 hours later on the same slave, clobberer thinks there's no need to clobber but CLOBBER correctly knows that there is

In fact, the configure check doesn't go far enough: since needs-clobber is typically symmetrical, and building the newer code and then going back and building the older code is just as likely to be broken, what we really need is to clobber when the two files differ.
I think client.mk should be doing this
That would be the squabblesome bug 837323. Alas, we can't do what we really need and clobber when the files differ, since objdir/CLOBBER is empty.
bug 837323 suggests putting this behaviour behind a mozconfig setting, which I agree with.

client.mk can easiy check if the files differ instead of basing its decisions on mtime.
With the proposal in bug 837323 comment 11, this will be fixed by that bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 837323
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.