Closed Bug 837448 Opened 7 years ago Closed 7 years ago

Intermittent test_emulator_loopback.js | ScriptTimeoutException: timed out

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25
Tracking Status
firefox24 --- unaffected
firefox25 --- fixed

People

(Reporter: philor, Assigned: vicamo)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

https://tbpl.mozilla.org/php/getParsedLog.php?id=19391589&tree=Mozilla-Inbound
b2g_ics_armv7a_gecko_emulator mozilla-inbound opt test marionette-webapi on 2013-02-02 17:33:22 PST for push b2f1089d6cd4
slave: talos-r3-fed-044

17:41:51    ERROR -  Traceback (most recent call last):
17:41:51     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 213, in runTest
17:41:51     INFO -      results = self.marionette.execute_js_script(js, args, special_powers=True)
17:41:51     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 478, in execute_js_script
17:41:51     INFO -      scriptTimeout=script_timeout)
17:41:51     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 249, in _send_message
17:41:51     INFO -      self._handle_error(response)
17:41:51     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 298, in _handle_error
17:41:51    ERROR -      raise ScriptTimeoutException(message=message, status=status, stacktrace=stacktrace)
17:41:51    ERROR -  TEST-UNEXPECTED-FAIL | test_emulator_loopback.js | ScriptTimeoutException: timed out
17:41:51     INFO -  ----------------------------------------------------------------------
17:41:51     INFO -  Ran 1 test in 11.076s
17:41:51    ERROR -  FAILED (errors=1)
Somehow the test script failed in the forth test case -- sending a long UCS2 encoded string.
Enable RIL debug messages and trying https://tbpl.mozilla.org/?tree=Try&rev=d3c0ba2a0ae4
Seems can't be easily reproduced :S
Assignee: nobody → vyang
Logs no longer available, and hasn't recurred in over 2 months, so I'm closing.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Saw this on Cedar with the new full emulator builds:
https://tbpl.mozilla.org/php/getParsedLog.php?id=24673269&tree=Cedar
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Note the above failure is perma-orange on the Cedar branch while running on the Ubuntu VM pool. We need to either fix or disable it before we can move the Mn tests over to those slaves on m-i/m-c.
Given that this is peram-orange on the ubuntu VM pool and green on the fedora pool, it's most likely a timing issue. Vicamo, any chance you can look into it or pass it along? Thanks!
Flags: needinfo?(vyang)
Don't know how to bind VMs from a specific pool.  Drop ownership.
Assignee: vyang → nobody
Flags: needinfo?(vyang)
Weird! I seem to be able to reproduce it with JB gonk.
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #16)
> Created attachment 775621 [details]
> qemu-jb-x86_test-emulator-loopback.txt

Somehow in line 52, emulator returned "AT+CMGS=87" instead of expected "AT+CMGS=149", and then in line 55, we got a new transaction with wrong parameters.
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #17)
> (In reply to Vicamo Yang [:vicamo][:vyang] from comment #16)
> > Created attachment 775621 [details]
> > qemu-jb-x86_test-emulator-loopback.txt
> 
> Somehow in line 52, emulator returned "AT+CMGS=87" instead of expected
> "AT+CMGS=149",

It's correct.  That's the length of followed SMS TEXT.

> and then in line 55, we got a new transaction with wrong parameters.

https://github.com/mozilla-b2g/platform_external_qemu/blob/master/telephony/sms.c#L476
In function |sms_address_eq()|, we should have following code instead:

  return ( !memcmp( addr1->data, addr2->data, (addr1->len + 1) / 2) );

because |addr1->len| is the number of digits, and SMS-ADDRESS packs two digits into one octet.  So sometimes the garbage data at the end fail the comparison, which in turn fails |sms_receiver_find_p()|, and then results in a new fragment created with wrong parameter.
Assignee: nobody → vyang
Attachment #775687 - Flags: review?(htsai)
Comment on attachment 775687 [details]
Github PR for platform/external/qemu

Thank you!!!
Attachment #775687 - Flags: review?(htsai) → review+
Merged on GitHub https://github.com/mozilla-b2g/platform_external_qemu/commit/8986e5942cb42e79c021b3317c6a82e726296ba2 .

@Andrew, could you help confirm this and update emulator HEAD?
Flags: needinfo?(ahalberstadt)
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #23)
> Merged on GitHub
> https://github.com/mozilla-b2g/platform_external_qemu/commit/
> 8986e5942cb42e79c021b3317c6a82e726296ba2 .
> 
> @Andrew, could you help confirm this and update emulator HEAD?

The emulator builds no longer need to be updated, they pull in the latest gonk/gaia/etc on their own and do a full stack build. So this should get picked up whenever the change gets mirrored over to the releng hg mirrors.

Thanks for the fix!
Flags: needinfo?(ahalberstadt)
This has gone green on Cedar, resolving
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
You need to log in before you can comment on or make changes to this bug.