HTML signature appears on one line across composition window

RESOLVED DUPLICATE of bug 488469

Status

MailNews Core
Account Manager
RESOLVED DUPLICATE of bug 488469
5 years ago
5 years ago

People

(Reporter: Edward, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
When the HTML box for a signature in e-mail is checked and the signature has multiple lines, all of the information is displayed in one row going across.  

Un-checking this box, will cause a multiple-line signature to correctly appear.


With HTML box unchecked, signature appears as typed in the Account Settings window, on multiple lines:

Name e-mail address
Company Name
http://web.address.here/


With HTML box checked, signature then appears all on one line, as:

Name e-mail address Company Name http://web.address.here/


With the HTML box checked, a multiple-line signature should appear as it was originally typed in the Account Settings window.  Not sure if this should be under MailNews: Account Configuration, or MailNews: Composition, as I'm not sure exactly where the bug resides.  

Behavior observed with Linux and Windows releases of SeaMonkey.
(Reporter)

Comment 1

5 years ago
Changing to MailNews Core, as this is also observed with Thunderbird.
Component: MailNews: Composition → Account Manager
Product: SeaMonkey → MailNews Core

Comment 2

5 years ago
That's expected, line breaks in HTML /code/ are to be ignored. For an explicit line break to be /displayed/, add <br> at the end of the lines, and it should work.

Note that "Use HTML" doesn't switch the signature box from plain-text to HTML mode, it only implies that the text entered is to be interpreted as HTML code in order to allow some basic formatting of the signature.

Converting the text box to an HTML-capable WYSIWYG editor box is bug 488469.

Comment 3

5 years ago
Edward, did comment #2 resolve the issue for you?
Whiteboard: [closeme 2013-03-04]
(Reporter)

Comment 4

5 years ago
For the multi-line signature, yes.

The /expected/ behavior would be bug 488469.

Comment 5

5 years ago
Ok, I'm thus marking your bug as a duplicate of the other one. A "true" HTML editor would certainly add <br> tags when you enter explicit line breaks, to this would solve that issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [closeme 2013-03-04]
Duplicate of bug: 488469
You need to log in before you can comment on or make changes to this bug.