We should not show download buttons on mozilla.org to users on FirefoxOS

RESOLVED DUPLICATE of bug 816825

Status

www.mozilla.org
Pages & Content
RESOLVED DUPLICATE of bug 816825
5 years ago
5 years ago

People

(Reporter: retornam, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=fxoslaunch p=, URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
STR:
1) Visit mozilla.org using the Firefox browser on FirefoxOS
2) Notice that download buttons are shown on the page. ( The download buttons are also broken when using FirefoxOS)


Expected Results:

Download buttons should not be shown to FirefoxOS users since they already have the Firefox browser installed by default

Comment 1

5 years ago
Created attachment 709759 [details]
Download buttons from Firefox OS

Comment 2

5 years ago
Created attachment 709760 [details]
Android button view from Firefox OS

Comment 3

5 years ago
pmac: Should we put this kind of logic within the new download button apps?
cmore: Yes I think it should. Should we just not show anything? That seems confusing. What should we show?
(Reporter)

Comment 5

5 years ago
(In reply to Paul McLanahan [:pmac] from comment #4)
> cmore: Yes I think it should. Should we just not show anything? That seems
> confusing. What should we show?

I think we should do one of the following:

1) Not show any buttons at all
2) Show a message saying you already have Firefox
Pmac and cmore:  I guess we need a comprehensive set of rules about not showing download buttons and redirects away from /fx and /new for Firefox OS users.  Want me to take a shot at writing something?

Comment 7

5 years ago
(In reply to jbertsch from comment #6)
> Pmac and cmore:  I guess we need a comprehensive set of rules about not
> showing download buttons and redirects away from /fx and /new for Firefox OS
> users.  Want me to take a shot at writing something?

Yeah and since the new download buttons will be on all Bedrock pages on launch, we should do this quickly. I'm fine with a message instead of just not displaying a download button. It may look weird even if downloading on Firefox OS is pointless.
Hi-

I'm not sure we need to hurry up now since very few people are actually using the FxOS phones and most of them are testers and developers. 

We definitely need a solution that accounts for both download pages and other pages with download button to determine appropriate messaging for most use cases.

It might even be a good idea to include this work in the Fx OS launch wave and brainstorm about it with the PMMs as we plan that wave.

Holly has offered to use Pmac's upcoming list of all places where a download button exists to map out what we should be doing for all use cases (iOs, Android, etc).

Is it OK all of you to work on this as part of the Fx OS launch wave?

Thx,
Jen
Whiteboard: u=user c=fxoslaunch p=

Updated

5 years ago
Blocks: 813052

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 816825
You need to log in before you can comment on or make changes to this bug.