Progress == ProgressMax in Mozilla embedding.

RESOLVED WORKSFORME

Status

()

Core
Embedding: APIs
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Brian 'netdragon' Bober, Assigned: Adam Lock)

Tracking

Trunk
All
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I am not sure where this goes. 

On the ACTIVEX control in Windows, in the OnProgressChange handler for the MFC
CWebBrowser2, for build 0.9.1, Progress == ProgressMax. ProgressMax should be 
the Maximum Progress, and not the same as Progress itself.

To copy, create the MFC project with the ACTIVEX control, and then make a text 
box. Handle the OnProgressChange handler and then send the values to the text 
box. (I wouldn't recommend debugging as it seems to crash MSVC++ with Mozilla 
embedding's OnProgressChange). You will notice the two values always equal each 
other.
(Reporter)

Comment 1

17 years ago
Created attachment 36921 [details]
Zip of a test application for win32 mfc (requires Adam Lock's activex component)

Comment 2

17 years ago
-> embedding i guess
Assignee: asa → adamlock
Component: Browser-General → Embedding APIs
QA Contact: doronr → mdunn
(Assignee)

Comment 3

17 years ago
I don't see this problem at all. Progress goes up from zero to whatever
progressMax is meant to be.
(Reporter)

Comment 4

17 years ago
what do you mean "What progressMax is meant to be"? If progressMax is 65535, 
then progress should go from 0 to 65535.

I recommend you use my test application only to test this, since it uses the 
MFC code that was given by the control. It is probably a problem in the MFC 
code itself. Although I'm not entirely sure. 

If my test application doesn't give you the same results on your computer, I'll 
cry.

If that happens, I'll try getting the same version of the control that you have.
(Assignee)

Comment 5

17 years ago
I tested your app and progress exactly as its meant to. Progress goes from 0 to
whatever progressMax is, whether that happens to be 50 or 50000 at the time. I
have to mark it WORKSFORME

I noticed why you had some confusion about Navigate() taking an LPCTSTR - MFC
has generated a wrapper around the actual method call that does the C string to
a BSTR conversion for you. Just pass in a TCHAR and it will do the conversion
for you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.