Remove MOZ_PSM build option and all #ifdef MOZ_PSM

RESOLVED FIXED in mozilla25

Status

--
enhancement
RESOLVED FIXED
6 years ago
10 months ago

People

(Reporter: briansmith, Assigned: briansmith)

Tracking

Trunk
mozilla25

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

I'm pretty sure that many things totally break without PSM now. mbanner says that removing this will make his maintenance of Thunderbird easier.
Assignee: nobody → brian
Target Milestone: --- → mozilla25
Created attachment 772244 [details] [diff] [review]
Remove MOZ_PSM option

This patch removes all references to MOZ_PSM in the tree.
Attachment #772244 - Flags: review?(gps)
Comment on attachment 772244 [details] [diff] [review]
Remove MOZ_PSM option

Review of attachment 772244 [details] [diff] [review]:
-----------------------------------------------------------------

This patch makes me happy.
Attachment #772244 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/4e24de97618a
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Created attachment 775686 [details] [diff] [review]
Remove MOZ_PSM from comm-central
Attachment #775686 - Flags: review?(mbanner)
Comment on attachment 775686 [details] [diff] [review]
Remove MOZ_PSM from comm-central

Review of attachment 775686 [details] [diff] [review]:
-----------------------------------------------------------------

For some reason, I thought I'd already removed this, but anyway, this looks good r=me.
Attachment #775686 - Flags: review?(mbanner) → review+

Updated

5 years ago
Duplicate of this bug: 784628

Updated

3 years ago
Blocks: 227792

Updated

10 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.