XMLHttpRequest problems with non-xml-style files...

VERIFIED DUPLICATE of bug 57673

Status

()

Core
XML
--
blocker
VERIFIED DUPLICATE of bug 57673
17 years ago
16 years ago

People

(Reporter: Gustav Munkby, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9) 
Gecko/20010505
BuildID:    {2001050515}

Reproducible: Always
Steps to Reproduce:
1. Create two pages (whatever.html and test.js)
2. write some javascript in the .js file and write this piece of javascript 
code in whatever.html

var o = new XMLHttpRequest();
o.open("GET","http://localhost/test.js", false);
o.send(null);
alert(o.responseText);

3. view the page whatever.html

Actual Results:  it freezes at send()...
if I try to do it asynchronously instead, then the onload event never triggers

Expected Results:  a popup box with the contents of test.js....

If I do the same thing in the javascript console, then mozilla will terminate 
when I try to close the console... null pointer exception somehow...

The instruction on "0x60098bac" referred to memory "0x00000000". The memory 
could not be "read"..
Onload not firing is bug 49949. 

As I understand it from other comments Heikki has made, sync loading isn't 
working currently. Bug 57673 will do as a dupe.

Gerv

*** This bug has been marked as a duplicate of 57673 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: petersen → rakeshmishra

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.