All users were logged out of Bugzilla on October 13th, 2018

mozilla crashes on helper apps with no file extension.

RESOLVED DUPLICATE of bug 60180

Status

--
critical
RESOLVED DUPLICATE of bug 60180
18 years ago
5 years ago

People

(Reporter: pfharlock, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
ummm, this is a longstanding bug in mozilla that everyone seems to be
overlooking.  It's repeatable with every helper application, not just
realplayer.  No-one has fixed it, and it's been there since version 0.7 of
mozilla.  I wish somebody would take this bug seriously.  heck, I even know
where the fault in the logic is.  The reason mozilla crashes is that whenever it
saves a temporary file for playback with a helper app it saves it with a file
extension equal to what you insert into the requester, if you don't enter in an
extension and mozilla trys to execute a prog it can't find a file extension and
doesn't know how to proceed so it just crashes.  an easy, (but cheesed), fix for
this problem would be to not allow people to leave that requester without
filling in that blank, a more complete solution would be to program into mozilla
a more intelligent way of handling such an error, ie go off of the file
extension that's already there instead of compoletely renaming the file, or even
better, not depend on the file extension at all for file identification and just
use the player that has the correct mimetype.  But hey, what do I know.

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 60180 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Depends on: 953430
No longer depends on: 953430
Depends on: 953433
No longer depends on: 953433
Depends on: 971241
If this bug is really NOT FIXED YET even though it was RESOLVED DUPLICATE in 2001, of something which is now VERIFIED WORKSFORME, the DUPLICATE should be removed. Or maybe it is indeed a duplicate and is not manifest anymore. Either way NOT FIXED YET does not belong in a one-line summary of the bug's permanent characteristics.

The only real action on this bug happened in 2001. Maybe it belongs in Core rather than in SeaMonkey.
Summary: mozilla crashes on helper apps with no file extension. NOT FIXED YET. → mozilla crashes on helper apps with no file extension.
You need to log in before you can comment on or make changes to this bug.