Closed Bug 838161 Opened 10 years ago Closed 10 years ago

Cannot accept Terms of Service for an already created bango account

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P1)

x86_64
Windows 7

Tracking

(Not tracked)

VERIFIED FIXED
2013-02-14

People

(Reporter: vcarciu, Assigned: cvan)

References

()

Details

(Whiteboard: c=mkt-payments u=dev p=1)

Prerequisites:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130113 Firefox/21.0

Steps to reproduce:
1.Login to MP-dev and go to Dev Hub
2.Submit a new paid app and click the "Manage Payments" button
3.Click on "Add or manage payment accounts" link
4.Try to accept Terms of Service for an existent account

Expected results:
User can accept Terms of Services without any issue

Actual results:
"Processing Requests" message is displayed for a long time and Terms and Services are not accepted

Please see screencast for this bug: http://screencast.com/t/U2ziJwD6k
Assignee: nobody → cvan
Version: 1.0 → 1.1
Priority: -- → P1
Target Milestone: 2013-02-07 → 2013-02-14
Whiteboard: p=
Whiteboard: p= → p=1
https://github.com/mozilla/zamboni/commit/a7d9cca
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Still not able to accept Terms and Services for an already created bango account : http://screencast.com/t/ED5uAROZM
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Victor, could you try creating a new Bango account but not agreeing to the TOS, then later agreeing to the TOS?
Whiteboard: p=1 → c=mkt-payments u=dev p=1
(In reply to Chris Van Wiemeersch [:cvan] from comment #4)
> Victor, could you try creating a new Bango account but not agreeing to the
> TOS, then later agreeing to the TOS?

Unfortunately , I am not able to test your scenario because of https://bugzilla.mozilla.org/show_bug.cgi?id=840540
Marking as fixed for re-verification. Thanks!
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
(In reply to Victor Carciu from comment #5)
> (In reply to Chris Van Wiemeersch [:cvan] from comment #4)
> > Victor, could you try creating a new Bango account but not agreeing to the
> > TOS, then later agreeing to the TOS?
> 
> Unfortunately , I am not able to test your scenario because of
> https://bugzilla.mozilla.org/show_bug.cgi?id=840540

Now I was able to test your scenario and for the new accounts I can accept the agreements later. I will mark the bug as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.