Extensions cannot be managed without a data connection (intentionally?).

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: taosk8r+bugzilla, Unassigned)

Tracking

({steps-wanted})

19 Branch
ARM
Android
steps-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

Moved the app to SD card.


Actual results:

Adblock and all my other extensions appear to have failed. None show up in the addon manager.


Expected results:

Apps path should have been updated, I would guess.
(Reporter)

Updated

6 years ago
Severity: normal → major
OS: Windows 7 → Android
Hardware: x86_64 → ARM
(Reporter)

Comment 1

6 years ago
Also remember that the screen darkened when attempting to switch lists in adblock, and dropdown was broken.
(Reporter)

Comment 2

6 years ago
Ok this appears to be caused by the lack of any data connection. Hadn't realized Fennec is dependent on an online connection just to view/manage extensions you have installed (really?).

The rest if likely just a bug with the actual extension, so I will seek further help from its authors.
(Reporter)

Updated

6 years ago
Summary: Extensions fail when app is moved to SD card. Moving back doesnt help. (Beta 19) Another lists this as fixed, but I still see it. → Extensions cannot be managed without a data connection (intentionally?).
(Reporter)

Comment 3

6 years ago
Changed the title to be more reflective of the issue.
(In reply to taosk8r+bugzilla from comment #2)
> Ok this appears to be caused by the lack of any data connection. Hadn't
> realized Fennec is dependent on an online connection just to view/manage
> extensions you have installed (really?).

There's no such dependancy. 

Do you have any steps to reproduce? I just tried installing Adblock Plus; quit Firefox, turned on Airplane mode. Re-opened Firefox, and visited the Add-Ons Manager, and it was still registered as an entry and still operational and tweak-able.
Keywords: steps-wanted
(Reporter)

Comment 5

6 years ago
Perhaps it does have to do with having moved fennec to the SD-Card, or perhaps it is related to the Android Version I am running (old phone). Not sure.
(Reporter)

Comment 6

6 years ago
Hmm.. Well, I did an update a few days ago. Just retested the issue, and it didn't happen this time, so I'm all good, thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.