Prefs from JS fail on ftp.mozilla.org bits on Windows

VERIFIED FIXED

Status

()

Core
Preferences: Backend
P1
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Steve Lamm, Assigned: neeti)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The sidebar uses prefs from JavaScript to save the open/close state.

The ftp.mozilla.org 6/16 bits for Windows do not load preferences properly.
The sweetlou bits reportedly work fine.

Alecf noticed that the prefs prog ID is not in the registry for the bits
from mozilla.org.

Alec, if you do not think you are the right person to look at this, assign
this back to me.
(Reporter)

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M7
(Reporter)

Comment 1

19 years ago
The previous bug tracking the problem was #8265, "Sidebar won't open". I fixed
the symptom but not the disease, so I opened this bug to track the latter.

Marking M7.
(Reporter)

Updated

19 years ago
Component: XPApps → libPref
Summary: Prefs from JS fail on ftp.mozilla.org bits on Windows
(Reporter)

Comment 2

19 years ago
*** Bug 8323 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
I know a fair bit about this, but my ideas are exhausted.
John, do you have any ideas?
My windows box is broken though, so I can't really debug this either.

Updated

19 years ago
Priority: P2 → P1
Target Milestone: M7 → M8

Comment 4

19 years ago
Because we have fixed the only known use of XPConnected prefs, I think we should
later this to M8 and raise the priority.

Updated

19 years ago
Assignee: alecf → mcmullen

Comment 5

19 years ago
I agree with slamm. Alec, while I am grateful for your work on libpref, I am
really the owner of it, so why don't I reassign this to myself?

Updated

19 years ago
Assignee: mcmullen → don
Target Milestone: M8 → M9

Comment 6

19 years ago
M9, giving to don for re-assigning.

Updated

19 years ago
Assignee: don → dp
Target Milestone: M9

Comment 7

19 years ago
dp ...

Updated

19 years ago
Assignee: dp → neeti

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
this is an old bug, it is all good now. Sidebar is fine, can be opened, closed,
and the states are saved

Comment 9

18 years ago
Moving all libPref component bugs to new Preferences: Backend component.  
libPref component will be deleted.
Component: libPref → Preferences: Backend
You need to log in before you can comment on or make changes to this bug.