Error flashing releng build from Windows machine

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: zcampbell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I have just tried to move from the A-team's eng builds to the RelEng builds.
I am using Windows 7 and Git Bash (nb before you laugh I don't dev in this, I just use it because up until now it has worked and it's the host OS/hardware).

When trying to flash I am getting this error message. I've tried with a couple of builds to no avail.

Zac@ZAC-VAIO /c/otoro_builds/unagi_2013-02-05_eng/b2g-distro
$ ./flash.sh
./flash.sh: line 209: conditional binary operator expected
./flash.sh: line 209: syntax error near `=~'
./flash.sh: line 209: ` if [[ "$VARIANT" =~ $USER_VARIANTS ]]; then'
Looks like you're using an old version of bash that's missing some syntax.  I think using a more recent version of bash is likely to have a large impact on this.

I'm going to close this bug, but please reopen if a newer version of bash (>4) reproduces this issue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.