Closed Bug 838553 Opened 7 years ago Closed 7 years ago

Can no longer compile optimized spidermonkey shell

Categories

(Core :: JavaScript Engine, defect, blocker)

x86
macOS
defect
Not set
blocker

Tracking

()

RESOLVED DUPLICATE of bug 838753

People

(Reporter: bzbarsky, Unassigned)

References

Details

This is a regression from bug 837773.

STEPS TO REPRODUCE:

 mkdir js/src/opt-obj && ( cd js/src && autoconf213 && ( cd opt-obj && ../configure --enable-profiling --enable-optimize --disable-debug && make -j6 ) )

or just try doing an optimized browser build.

EXPECTED RESULTS: Compiles.

ACTUAL RESULTS:

  Undefined symbols for architecture x86_64:
    "JSAtom* js::ToAtom<(js::AllowGC)1>(JSContext*, JS::Value const&)",
  referenced from:
        JS::detail::ToPropertyKeySlow(JSContext*, JS::Handle<JS::Value>,
  JS::PropertyKey*) in PropertyKey.o
  ld: symbol(s) not found for architecture x86_64
  clang: error: linker command failed with exit code 1 (use -v to see
    invocation)

ADDITIONAL INFORMATION: I'm using clang svn rev 163716 but jonco was seeing this on the Apple "4.1" release as well, which is the theoretically currently supported clang.
Note that this also breaks browser builds, since those build a shell...
I'd bet you won't see this with bug 838753 fixed.
Indeed, that patch seems to fix this bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 838753
You need to log in before you can comment on or make changes to this bug.