[CONTACTS][FACEBOOK] Inconsistent notification of the number of Facebook friends available to import

VERIFIED FIXED in Firefox OS v1.4

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: maat, Assigned: Jose Manuel Cantera)

Tracking

unspecified
1.4 S3 (14mar)
x86
Mac OS X
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g-v1.4 verified)

Details

(Whiteboard: interaction [UX-P2], [TEF_REQ])

Attachments

(6 attachments)

(Reporter)

Description

5 years ago
[CONTACTS][FACEBOOK] Inconsistent notification of the number of Facebook friends available to import

**DESCRIPTION**
Inconsistent notification of the number of Facebook friends available to import

i suspect that this is related to Bug 837726 but this bug is raised to specifically highlight that the number of friends available to import is presented inconsistently.

**PATH**
to set the context for this test i am connected to 145 people in Facebook and non are deactivated

1) open an empty contact list
2) select the settings icon in the top right hand corner of the screen
3) select Facebook not enables yet
4) log into Facebook
5) select all contacts to be imported
6) select import
7) observe the total number of friends to be imported during import (in my case 139 refer to screenshot 01)
8) once import is completed select the settings icon in the top right hand corner of the contact list and observe the total number of friends available to import (in my cace 145 refer to screenshot 02) 
9) select the 'update imported friends' CTA
10) Observe the statement 'All your friends are imported' at the top of the Facebook Friends list.
11) scroll the Facebook Friends list and note that all the friends listed are selected
12) select the X in the top left hand corner of the Facebook Friends list
13) observe the total number of friends available to import is now different (in my case 139 refer to screenshot 03)
14) select the 'update imported friends' CTA
15) select 'Deselect all'
16) select 'update'
17) observe the total number of friends to be updated during import (in my case 139 refer to screenshot 04)
18) once the update is completed select the settings icon in the top right hand corner of the contact list and observe the total number of friends available to import (in my cace 145 refer to screenshot 05) 

**EXPECTED**
in all instances where the number of friends available to import from Facebook is presented the number will be consistent

**ACTUAL**
there is inconsistency in the number of friends available to import from Facebook in different instances where the number is presented.
(Reporter)

Comment 1

5 years ago
Created attachment 710696 [details]
screenshot 01 refer to step 7
(Reporter)

Comment 2

5 years ago
Created attachment 710699 [details]
screenshot 02 refer to step 8
(Reporter)

Comment 3

5 years ago
Created attachment 710700 [details]
screenshot 03 refer to step 13
(Reporter)

Comment 4

5 years ago
Created attachment 710701 [details]
screenshot 04 refer to step 17
(Reporter)

Comment 5

5 years ago
Created attachment 710703 [details]
screenshot 05 refer to step 18
(Reporter)

Updated

5 years ago
Whiteboard: interaction [UX-P2], [TEF_REQ]

Updated

4 years ago
Duplicate of this bug: 970899

Updated

4 years ago
blocking-b2g: --- → 1.3?
At triage we agreed that this would not block release 1.3.

Moving to 1.4 for radar.
blocking-b2g: 1.3? → 1.4?
let's block on it to definitely fix it
blocking-b2g: 1.4? → 1.4+
(Assignee)

Comment 9

4 years ago
(In reply to David Scravaglieri [:scravag] from comment #8)
> let's block on it to definitely fix it

We will try to fix it but it depends on a fix from FB. We will get in touch with FB and try to get it fixed ...
(Assignee)

Updated

4 years ago
Assignee: nobody → jmcf
(Assignee)

Comment 10

4 years ago
Created attachment 8387526 [details]
16987.html
Attachment #8387526 - Flags: review?(crdlc)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 831026
(Assignee)

Updated

4 years ago
Attachment #8387526 - Flags: review?(francisco.jordano)
Attachment #8387526 - Flags: review?(crdlc)
Attachment #8387526 - Flags: feedback?(crdlc)
Thx! Don't forget the unit test so we can mark it as intest-suite :)
Comment on attachment 8387526 [details]
16987.html

LGTM, I gave some comments on Github without high importance. Good job
Attachment #8387526 - Flags: feedback?(crdlc) → feedback+
Can we add tests for this patch?
Flags: needinfo?(jmcf)
(Assignee)

Comment 15

4 years ago
Yes, of course, now are done, waiting for your review

thanks!
Flags: needinfo?(jmcf)
Comment on attachment 8387526 [details]
16987.html

Great work, please take a look to the unit tests in travis, seems right now are failing cause of this PR.

Merge once travis is ok :)
Attachment #8387526 - Flags: review?(francisco.jordano) → review+
(Assignee)

Comment 17

4 years ago
landed in master:

https://github.com/mozilla-b2g/gaia/commit/64baeca8296fd51f0d438a779ee040e0ee8d6dd2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Flags: in-testsuite+
(Assignee)

Updated

4 years ago
Keywords: verifyme

Updated

4 years ago
Target Milestone: --- → 1.4 S3 (14mar)
Tested and working
Hamachi
Build ID: 20140313071526
Git commit: b5d0f9b0
Platform version: 30.0a1
Status: RESOLVED → VERIFIED
status-b2g-v1.4: --- → fixed

Comment 19

4 years ago
1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140527000202
Gaia: 0542778892a294d224e75af4a76be5d42938bc90
Gecko: d583ae109f54
Version: 30.0
Firmware Version: v1.2-device.cfg

1.4: 212 of 214 contacts consistently appear, same 2 contacts do not appear throughout entire process.
status-b2g-v1.4: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.