[Inari] Home button frequently becomes unresponsive

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Homescreen
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MWCDemo2013])

STR:
1. Launch the maps app
2. Press the home button multiple times

Expected: Nothing happens
Actual: It should move the app to card view

During testing this evening I saw this issue multiple times, in different conditions. Sometimes if you hammered on the button 10 times it would finally do something, but not always.
* Gaia: 3df466a3a11
* BuildID: 20130204095214

Updated

5 years ago
blocking-b2g: tef? → ---

Comment 2

5 years ago
Tested on Build ID : 20130207023449
Git Commit Info : 2013-02-06 14:30:07  d23401f1c1ee2a46185cbdd460c3607…

I had this issue when I was testing the Email app.

STR :
1. Launch Email app
2. Try to read a new unread mail - tap on the unread mail several times
3. Tap on the home button several times

Expected : Nothing happens
Actual : Home screen should be shown.

As marcia said, this occurred several times (during different app testings)

Comment 3

5 years ago
i have a higher reproducible scenario:

1) launch any app
2) hit the power button to turn off screen
3) hit it again to turn it on, and unlock screen
4) try tapping the home button when the app opens

Verify you need to hammer down on the home button a little harder than normal to exit.  Prior to step 2, you could tap and close the app at a comfortable velocity.

logcat:
02-06 18:04:41.944: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:225280 offset:6041600 fd:116
02-06 18:04:41.944: D/memalloc(680): /dev/pmem: Mapped buffer base:0x45487000 size:6266880 offset:6041600 fd:34
02-06 18:04:41.954: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:90112 offset:81920 fd:121
02-06 18:04:41.954: D/memalloc(680): /dev/pmem: Mapped buffer base:0x424cd000 size:172032 offset:81920 fd:37
02-06 18:04:42.034: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:225280 offset:6266880 fd:149
02-06 18:04:42.044: D/memalloc(680): /dev/pmem: Mapped buffer base:0x45a81000 size:6492160 offset:6266880 fd:40
02-06 18:04:42.054: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:163840 offset:6492160 fd:155
02-06 18:04:42.054: D/memalloc(680): /dev/pmem: Mapped buffer base:0x46133000 size:6656000 offset:6492160 fd:43
02-06 18:04:42.064: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:90112 offset:6656000 fd:175
02-06 18:04:42.064: D/memalloc(680): /dev/pmem: Mapped buffer base:0x46860000 size:6746112 offset:6656000 fd:46
02-06 18:04:42.074: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:163840 offset:2150400 fd:178
02-06 18:04:42.074: D/memalloc(680): /dev/pmem: Mapped buffer base:0x46edb000 size:2314240 offset:2150400 fd:49
02-06 18:04:42.184: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:163840 offset:2314240 fd:183
02-06 18:04:42.184: D/memalloc(680): /dev/pmem: Mapped buffer base:0x471f4000 size:2478080 offset:2314240 fd:52
02-06 18:04:42.194: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:163840 offset:2478080 fd:191
02-06 18:04:42.194: D/memalloc(680): /dev/pmem: Mapped buffer base:0x474b9000 size:2641920 offset:2478080 fd:55
02-06 18:04:42.194: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:163840 offset:2641920 fd:195
02-06 18:04:42.194: D/memalloc(680): /dev/pmem: Mapped buffer base:0x4773f000 size:2805760 offset:2641920 fd:58
02-06 18:04:42.204: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:163840 offset:2805760 fd:198
02-06 18:04:42.204: D/memalloc(680): /dev/pmem: Mapped buffer base:0x47a18000 size:2969600 offset:2805760 fd:61
02-06 18:04:42.414: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x474b9000 size:2641920 offset:2478080
02-06 18:04:42.414: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x47a18000 size:2969600 offset:2805760
02-06 18:04:42.414: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a8a2000 size:163840 offset:2314240 fd:183
02-06 18:04:42.414: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a8ca000 size:163840 offset:2478080 fd:191
02-06 18:04:42.414: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4ac9e000 size:163840 offset:6492160 fd:155
02-06 18:04:42.414: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a8f2000 size:163840 offset:2641920 fd:195
02-06 18:04:42.414: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a91a000 size:163840 offset:2805760 fd:198
02-06 18:04:42.414: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a87a000 size:163840 offset:2150400 fd:178
02-06 18:04:42.414: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x471f4000 size:2478080 offset:2314240
02-06 18:04:42.424: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x46133000 size:6656000 offset:6492160
02-06 18:04:42.424: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x4773f000 size:2805760 offset:2641920
02-06 18:04:42.424: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x46edb000 size:2314240 offset:2150400
02-06 18:04:42.464: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4ac30000 size:225280 offset:6041600 fd:116
02-06 18:04:42.474: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x45487000 size:6266880 offset:6041600
02-06 18:04:42.474: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x424cd000 size:172032 offset:81920
02-06 18:04:42.474: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4ac67000 size:225280 offset:6266880 fd:149
02-06 18:04:42.474: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a681000 size:90112 offset:81920 fd:121
02-06 18:04:42.474: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4acc6000 size:90112 offset:6656000 fd:175
02-06 18:04:42.484: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x45a81000 size:6492160 offset:6266880
02-06 18:04:42.484: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x46860000 size:6746112 offset:6656000
02-06 18:04:44.687: I/IdleService(109): next timeout 1000 msec from now
02-06 18:04:44.687: I/IdleService(109): SetTimerExpiryIfBefore: next timeout 1000 msec from now
02-06 18:04:44.687: I/IdleService(109): reset timer expiry to 1008 msec from now
02-06 18:04:44.687: I/IdleService(109): Reset idle timeout: tell observer 47b99e40 user is back
02-06 18:04:44.967: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:614400 offset:6041600 fd:116
02-06 18:04:44.977: D/memalloc(462): /dev/pmem: Mapped buffer base:0x44e00000 size:6656000 offset:6041600 fd:30
02-06 18:04:44.977: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:8192 offset:6656000 fd:121
02-06 18:04:44.987: D/memalloc(462): /dev/pmem: Mapped buffer base:0x454d6000 size:6664192 offset:6656000 fd:33
02-06 18:04:44.987: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:368640 offset:2150400 fd:149
02-06 18:04:44.987: D/memalloc(462): /dev/pmem: Mapped buffer base:0x43e00000 size:2519040 offset:2150400 fd:36
02-06 18:04:45.017: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:12288 offset:6664192 fd:155
02-06 18:04:45.017: D/memalloc(462): /dev/pmem: Mapped buffer base:0x45b31000 size:6676480 offset:6664192 fd:39
02-06 18:04:45.017: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:122880 offset:2519040 fd:175
02-06 18:04:45.027: D/memalloc(462): /dev/pmem: Mapped buffer base:0x44067000 size:2641920 offset:2519040 fd:42
02-06 18:04:45.057: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:614400 offset:2641920 fd:178
02-06 18:04:45.057: D/memalloc(462): /dev/pmem: Mapped buffer base:0x44800000 size:3256320 offset:2641920 fd:45
02-06 18:04:45.057: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:8192 offset:6676480 fd:183
02-06 18:04:45.057: D/memalloc(462): /dev/pmem: Mapped buffer base:0x4618f000 size:6684672 offset:6676480 fd:48
02-06 18:04:45.067: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:368640 offset:3256320 fd:191
02-06 18:04:45.067: D/memalloc(462): /dev/pmem: Mapped buffer base:0x4680e000 size:3624960 offset:3256320 fd:51
02-06 18:04:45.067: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:12288 offset:6684672 fd:195
02-06 18:04:45.067: D/memalloc(462): /dev/pmem: Mapped buffer base:0x46bd6000 size:6696960 offset:6684672 fd:56
02-06 18:04:45.077: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:122880 offset:3624960 fd:198
02-06 18:04:45.077: D/memalloc(462): /dev/pmem: Mapped buffer base:0x47309000 size:3747840 offset:3624960 fd:59
02-06 18:04:45.107: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:81920 offset:81920 fd:201
02-06 18:04:45.127: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4aad2000 size:81920 offset:4608000 fd:66
02-06 18:04:45.137: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a66d000 size:81920 offset:0 fd:100
02-06 18:04:45.247: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:81920 offset:0 fd:66
02-06 18:04:45.457: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a66d000 size:81920 offset:0 fd:66
02-06 18:04:45.467: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a681000 size:81920 offset:81920 fd:201
02-06 18:04:45.467: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4aae6000 size:532480 offset:4689920 fd:166
02-06 18:04:45.467: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a7f8000 size:532480 offset:1617920 fd:105
02-06 18:04:45.537: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:204800 offset:1617920 fd:66
02-06 18:04:45.537: D/memalloc(680): /dev/pmem: Mapped buffer base:0x45487000 size:1822720 offset:1617920 fd:34
02-06 18:04:45.547: D/memalloc(109): /dev/pmem: Allocated buffer base:0x4a66d000 size:81920 offset:0 fd:101
02-06 18:04:45.547: D/memalloc(680): /dev/pmem: Mapped buffer base:0x424dd000 size:81920 offset:0 fd:37
02-06 18:04:45.587: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a730000 size:819200 offset:798720 fd:73
02-06 18:04:45.587: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a7f8000 size:204800 offset:1617920 fd:66
02-06 18:04:45.587: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4a66d000 size:81920 offset:0 fd:101
02-06 18:04:45.587: D/memalloc(109): /dev/pmem: Freeing buffer base:0x4ab68000 size:819200 offset:5222400 fd:185
02-06 18:04:45.587: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x44ec4000 size:6041600 offset:5222400
02-06 18:04:45.627: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x44d00000 size:1617920 offset:798720
02-06 18:04:45.627: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x45487000 size:1822720 offset:1617920
02-06 18:04:45.637: D/memalloc(680): /dev/pmem: Unmapping buffer base:0x424dd000 size:81920 offset:0
02-06 18:04:45.688: I/IdleService(109): Get idle time: time since reset 866 msec
02-06 18:04:45.688: I/IdleService(109): Idle timer callback: current idle time 866 msec
02-06 18:04:45.688: I/IdleService(109): next timeout 133 msec from now
02-06 18:04:45.688: I/IdleService(109): SetTimerExpiryIfBefore: next timeout 133 msec from now
02-06 18:04:45.688: I/IdleService(109): reset timer expiry to 143 msec from now
02-06 18:04:45.838: I/IdleService(109): Get idle time: time since reset 1010 msec
02-06 18:04:45.838: I/IdleService(109): Idle timer callback: current idle time 1010 msec
02-06 18:04:45.838: I/IdleService(109): next timeout 4294967293988 msec from now
02-06 18:04:45.838: I/IdleService(109): SetTimerExpiryIfBefore: next timeout 4294967293987 msec from now
02-06 18:04:45.838: I/IdleService(109): reset timer expiry to 4294967293996 msec from now
02-06 18:04:45.838: I/IdleService(109): Idle timer callback: tell observer 47b99e40 user is idle
02-06 18:04:45.848: I/IdleService(109): Get idle time: time since reset 1019 msec

Comment 4

5 years ago
hmm, this logcat data seems more useful:

02-06 18:07:03.652: I/ONCRPC(113): rpc_handle_rpc_call: for Xid: 3b2f, Prog: 31000000, Vers: fc37ad5c, Proc: 00000012
02-06 18:07:03.652: I/ONCRPC(113): rpc_handle_rpc_call: Find Status: 0 Xid: 3b2f
02-06 18:07:03.652: I/ONCRPC(113): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 3b2f
02-06 18:07:03.802: I/GonkMemoryPressure(462): Checking to see if memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(462): Memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(109): Checking to see if memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(109): Memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(548): Checking to see if memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(548): Memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(643): Checking to see if memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(643): Memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(699): Checking to see if memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(699): Memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(613): Checking to see if memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(613): Memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(787): Checking to see if memory pressure is over.
02-06 18:07:03.802: I/GonkMemoryPressure(787): Memory pressure is over.
02-06 18:07:03.812: I/GonkMemoryPressure(680): Checking to see if memory pressure is over.
02-06 18:07:03.812: I/GonkMemoryPressure(680): Memory pressure is over.

Comment 5

5 years ago
Hi all,

If you meet this issue again, could you help to use command as below to record the touch event?
(event0 should be the touch device on inari)

  adb shell getevent -l /dev/input/event0

So at least we can figure out whether this is a issue below the Firefox OS.
Thanks.

Comment 6

5 years ago
This is a kernel driver issue and it has already been reported to the vendor.

Comment 7

5 years ago
(In reply to Michael Wu [:mwu] from comment #6)
> This is a kernel driver issue and it has already been reported to the vendor.

Any workaround in the meantime?   nom'ing this to be a mwc blocker.
FWIW.  I do not see this with the tip kernel.
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.