mochitest-metro-chrome tests failing with several nsGlobalWindow leaked until shutdown

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Metro browser-chrome tests are failing with the following errors:

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser_plugin_input_keyboard.js | leaked until shutdown [nsGlobalWindow #25 chrome://mochitests/content/metro/browser_plugin_input.html]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser_onscreen_keyboard.js | leaked until shutdown [nsGlobalWindow #22 chrome://mochitests/content/metro/browser_onscreen_keyboard.html]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser_context_ui.js | leaked until shutdown [nsGlobalWindow #19 about:]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser_context_ui.js | leaked until shutdown [nsGlobalWindow #16 about:]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser_plugin_input_keyboard.js | leaked until shutdown [nsGlobalWindow #23 chrome://mochitests/content/metro/browser_plugin_input.html]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser_onscreen_keyboard.js | leaked until shutdown [nsGlobalWindow #20 chrome://mochitests/content/metro/browser_onscreen_keyboard.html]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser_context_ui.js | leaked until shutdown [nsGlobalWindow #17 about:]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser_context_ui.js | leaked until shutdown [nsGlobalWindow #14 about:]

This seems to be a regression from bug 836963.  Specifically, commenting out this event listener fixes the leaks:

http://hg.mozilla.org/projects/elm/rev/cbb24f3d4d11#l1.106
(Assignee)

Comment 1

6 years ago
Created attachment 710807 [details] [diff] [review]
patch

I wonder if desktop could use the same fix, or if they are protected for some reason.

I also wonder if we get a leak when _attachToInput is called.
Attachment #710807 - Flags: review?(netzen)
Comment on attachment 710807 [details] [diff] [review]
patch

Review of attachment 710807 [details] [diff] [review]:
-----------------------------------------------------------------

> I wonder if desktop could use the same fix, or if they are protected for some reason.

It seems like it from:
dxr.mozilla.org/mozilla-central/toolkit/components/passwordmgr/nsLoginManager.js.html
But I'm not sure.  Thanks for picking this up.
Attachment #710807 - Flags: review?(netzen) → review+
(Assignee)

Comment 3

6 years ago
http://hg.mozilla.org/projects/elm/rev/cd95fa05c8fe

I'll file a follow-up to investigate this on desktop.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Blocks: 838948
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.