Closed Bug 838713 Opened 7 years ago Closed 7 years ago

Skip slow-startup-check if Services.startup.interrupted is true

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 22
Tracking Status
firefox20 --- unaffected
firefox21 + fixed

People

(Reporter: jaws, Assigned: dao)

References

Details

Attachments

(1 file)

The measurements are less reliable in these conditions and aren't likely representative of a true "slow" startup.
I'm not sure what impact this can have, :vladan may know more, but we shouldn't alert users about a slow startup if the slow startup was the result of an update.
Flags: needinfo?(vdjeric)
This flag is set if the extension update dialog pops up after launching an updated version of Firefox (i.e. "Checking your add-ons for compatibility with this version of Firefox"). It delays some of the startup milestones
Flags: needinfo?(vdjeric)
Assignee: nobody → dao
Attached patch patchSplinter Review
Attachment #715507 - Flags: review?(jAwS)
Attachment #715507 - Flags: review?(jAwS) → review+
https://hg.mozilla.org/mozilla-central/rev/b399e0488c09
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Comment on attachment 715507 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 836010
User impact if declined: slow startup notification showing up based on bogus startup measurements
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none
Attachment #715507 - Flags: approval-mozilla-aurora?
Attachment #715507 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Is there anything QA can do to verify this is fixed?
Blocks: 868400
You need to log in before you can comment on or make changes to this bug.