Payment: Allow support for multiple SIM card

RESOLVED WONTFIX

Status

Marketplace
Payments/Refunds
P3
enhancement
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: dbialer, Assigned: Steve Ruston)

Tracking

x86
Mac OS X
Points:
---

Details

(Reporter)

Description

5 years ago
From David Lozano describing issue:
We're just discussing on how to optimize the authentication on the user for the payments flow. As you all know:

  *   when the user is in 3G, we can automatically authenticate him based on mobileId. Bango will receive an alias – the mobileid -, not the final user's phone number.
  *   When the user is in Wifi, Bango will send an SMS with a validation code to authenticate the user an get the clear-text phone number.

The question is that we're trying to optimize the above to streamline the process as much as possible, so we want to use cookies. Current approach is to use a cookie (set from Bango on the terminal) to remember previous authentications:

  *   if the cookie is set when accessing thru 3G, a mobile Id is remembered for later purchases
  *   If the cookie is set when accessing thru wifi, a mobile number is remembered for later purchases

The problem is that we have no way to detect when the user changes the SIM card. Do we want the user to put charges always to the phone number associated to the SIM being used in that specific moment? What if the SIM card happens to not belong to Telefónica, but other operator? Additionally, for cookies set when accessing by wifi, we can show the user "do you want to pay xxx with phone number 1234", so the user can opt to proceed or not, but we can't show the phone number for cookies set when accessing thru 3G. Therefor, the following looks reasonable:

  *   if we think that users changing the SIM "regularly" is going to be common case => we should not use cookies at all for 3G accesses and forget about optimizing that part. We could still use cookies for wifi.
  *   If we think that the above is going to be really strange, then we could use cookies also for 3G accesses. Our current view was on this second option (as we do similar things for other partners), with the compromise of having a cookie for 3G accesses that would expire after 24 hours and I also think if would be reasonable to have a different cookie that would have a longer expiration time for wifi.

Updated

5 years ago
Assignee: nobody → sruston
Severity: normal → enhancement
Whiteboard: p=
Priority: -- → P3
Version: 1.0 → 1.4
Assignee: sruston → amckay

Comment 1

5 years ago
When a new SIM is inserted we log the user out of Bango, forcing them to log back in through persona, see bug 872751.

We pass through the persona id to Bango which they can use, see bug 880007.

A "choose which SIM to pay with" is going to need some UX help to figure out so assigning to Maureen to see if there's anything else we need to do here.
Assignee: amckay → mhanratty
Whiteboard: p= → [ux-wanted]
(In reply to Andy McKay [:andym] from comment #1)
> 
> We pass through the persona id to Bango which they can use, see bug 880007.

This is not the correct bug link because it only applies to Seahorse. You meant bug 893050 which is a request to always link MOZ_USER_ID to billing identity. However, I don't think that applies to multiple SIM card support. All we really need is the logout functionality.

Comment 3

4 years ago
Is there(In reply to Kumar McMillan [:kumar] from comment #2)
> However, I don't think that applies to multiple SIM card support.
> All we really need is the logout functionality.

So is there anything Maureen needs to do here? Looking for the next steps.
Flags: needinfo?(kumar.mcmillan)
(In reply to Andy McKay [:andym] from comment #3)
> So is there anything Maureen needs to do here? Looking for the next steps.

Personally, I don't think any UX change is needed for this. When a user swaps in a new SIM, they will be charged on that SIM. No need for a prompt. The user chose to put in the new SIM so why do we need to prompt them?

Swapping SIMs will work seamlessly today using mobile ID but on wifi they will have to re-auth after every SIM swap which could be annoying. If we want to fix the wifi case we'll need Bango to adjust their cookie logic to support multiple SIMs (which is possible using the unique ICC number).
Flags: needinfo?(kumar.mcmillan)

Comment 5

4 years ago
Q: "Do we want the user to put charges always to the phone number associated to the SIM being used in that specific moment?"

A: Yes

I agree with Kumar, just charge to the SIM that is in the card without prompting.
(Reporter)

Comment 6

4 years ago
Added dependency on Bug 893050 for WiFi case - and this only applies to operator billing.

Adding a dependency on logout support (if not already there)
Depends on: 893050
(Reporter)

Comment 7

4 years ago
(In reply to David Bialer [:dbialer] from comment #6)
> Added dependency on Bug 893050 for WiFi case - and this only applies to
> operator billing.
> 
> Adding a dependency on logout support (if not already there)

Referring to Comment 4 (we'll need Bango to adjust their cookie login to support multiple SIM) - what would need to happen.  Bug 917705 is now open for Firfox OS to support Multiple SIMs.
(Reporter)

Updated

4 years ago
Assignee: mhanratty → nobody
Flags: needinfo?(amckay)
Whiteboard: [ux-wanted]

Updated

4 years ago
Blocks: 937504

Comment 8

4 years ago
Adding in the addition of the ICC info into the Bango cookie sounds valid from comment 4. Tom does that make sense to you?
Assignee: nobody → tom
Flags: needinfo?(amckay)
(Reporter)

Comment 9

4 years ago
This sounds like it may need a privacy review?

Updated

4 years ago
Assignee: tom → Jim

Comment 10

4 years ago
Discussed with Bango Product Management and Development.

The proposed way forward on this would be:

* On SIM change, Mozilla OS to trap the change (even if change out and change back)
* Bango integration could be enhanced to support passing input of "SIM changed flag"
* On SIM changed flag = true, WiFi cookie will be invalidated
* On SIM changed flag = true, 3G authentication will be re-done
* Following payments (on wi fi or data) will always be on the "inserted SIM"

This behaviour best matches user expectation for payments on their phone bill.  With Silent SMS feature - repeated authentication due to SIM swap will be invisible in most cases.

In cases where SIM changed cannot be passed, the use of Persona ID will allow more control (i.e. mozilla preferences page on Bango ID to bill can be implemented).

Note: there is no Bango intent to implement "MultiSIM" billing support.

Updated

4 years ago
Version: 1.4 → 1.5

Comment 11

4 years ago
Pending feedback from Mozilla
(Assignee)

Updated

4 years ago
Assignee: Jim → sruston

Comment 12

4 years ago
It isn't a RIL feature.
No longer blocks: 937504

Updated

4 years ago
Summary: Allow support for multiple SIM card → Payment: Allow support for multiple SIM card
(Assignee)

Comment 13

3 years ago
There is no specific support for Multi sim on the Bango side.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.