Simplify device name on Sync settings UI

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
23 days ago

People

(Reporter: ywang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 710961 [details]
mockup-simplify device name

Currently if you set up Sync on Windows 8, Sync UI shows the full name of your connected device. It's a long name. Not friendly to read and hard to edit on touch screen device.

The proposal is to simplify the device name and avoid letting users to let it. Since the users are using the Operation System to sync, showing the user's name and browser's name should be enough to identify the current device. 

For example, instead of showing "Yuan's Nightly on Windows NT 6.2;WOW64", show "Yuan's Nightly".

Firefox Sync on Andorid has already simplified device names on Settings. I assume this could apply to other platform as well.
This name is used on other devices to identify it (e.g for sending tabs). It has to be unique across platforms.
I agree there should be a unique name for transferring information from a technical perspective. 

I assumed editing from the users does not change the name for transferring information across devices.

If this name shown on the Sync UI has to be unique, what's reason of having a free-editing field for device name? How to avoid duplication?
(In reply to Yuan Wang(:Yuan) – Firefox UX Team from comment #2)
> I agree there should be a unique name for transferring information from a
> technical perspective. 
> 
> I assumed editing from the users does not change the name for transferring
> information across devices.
> 
> If this name shown on the Sync UI has to be unique, what's reason of having
> a free-editing field for device name? How to avoid duplication?

Clients advertise their own name in their server record. There's one record per client.

Each record has:

  * A unique GUID
  * A name string
  * A type (mobile/desktop).

When you set up a new desktop device, you're given the option to provide a name: "Richard's Windows tablet", or "Test device 2". We pre-populate with a default string that tries to strike a balance between brevity and uniqueness, because non-unique names are disruptive (e.g., Bug 618509).

Having a user-editable name makes functionality like Send Tab more pleasant: I can choose to send to "Work laptop" instead of "rnewman's Firefox on Mac OS X". And if you have two similar devices, there's no good way to come up with a short, descriptive name: two Macs running Firefox Beta will probably collide.

The shorter you make the names (e.g., dolske's suggestion of "Android mobile", "Mac desktop"), the higher the chance of collision.

We assume that users will be better at coming up with unique, descriptive names than our code, because they have so many more concepts available to them, and so we give them the option.

Android Sync doesn't allow you to change the name, simply because we've never had enough resources to work on improving the setup flow. (This is Bug 788688.) It also doesn't allow you to sign up for a new account, for the same reason.

See also Bug 679272, which is probably a good dupe target for this bug.
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
Thom to check if this still happens.
Flags: needinfo?(tchiovoloni)
I set up a few profiles on windows machines and confirmed that they look fine now.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(tchiovoloni)
Resolution: --- → WORKSFORME
(Assignee)

Updated

23 days ago
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.