Last Comment Bug 838839 - Remove deprecated synchronous favicons APIs
: Remove deprecated synchronous favicons APIs
Status: RESOLVED FIXED
: dev-doc-needed
Product: Toolkit
Classification: Components
Component: Places (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla22
Assigned To: Marco Bonardo [::mak]
:
Mentors:
Depends on:
Blocks: 834457
  Show dependency treegraph
 
Reported: 2013-02-06 14:21 PST by Marco Bonardo [::mak]
Modified: 2013-03-21 06:08 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1.0 (51.37 KB, patch)
2013-02-06 15:17 PST, Marco Bonardo [::mak]
no flags Details | Diff | Splinter Review
patch v1.1 (51.14 KB, patch)
2013-02-28 01:35 PST, Marco Bonardo [::mak]
asaf: review+
gavin.sharp: superreview+
Details | Diff | Splinter Review

Description Marco Bonardo [::mak] 2013-02-06 14:21:07 PST
Another piece going.
Comment 1 Marco Bonardo [::mak] 2013-02-06 15:17:42 PST
Created attachment 711005 [details] [diff] [review]
patch v1.0

A couple notes:

1. the XXXIfAvailable helpers were been added lots of time ago before I did the Database.cpp refactoring, when I refactored the shutdown code I didn't remove them. Since I was removing the entry in favicons I just removed the others in bookmarks and annotations.

2. mFaviconsExpirationRunning was used to avoid sync APIs adding stuff while async expiration was running, by mistake it was then added also to async APIs, but actually they don't need it since everything on a connection is serialized.

As usual, will hit Try before landing.
Comment 2 Marco Bonardo [::mak] 2013-02-26 11:56:27 PST
Comment on attachment 711005 [details] [diff] [review]
patch v1.0

Review of attachment 711005 [details] [diff] [review]:
-----------------------------------------------------------------

I must unbitrot the patch due to recent changes to notify deprecation, though we can proceed with SR in parallel to the review
Comment 3 Marco Bonardo [::mak] 2013-02-28 01:35:36 PST
Created attachment 719398 [details] [diff] [review]
patch v1.1

just an unbitrot
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-02-28 09:50:44 PST
Comment on attachment 719398 [details] [diff] [review]
patch v1.1

The forward declaration of nsIFaviconDataCallback at the top of nsIFaviconService should no longer be needed.
Comment 6 Ed Morley [:emorley] 2013-03-21 06:08:13 PDT
https://hg.mozilla.org/mozilla-central/rev/c9c29cc97af0

Note You need to log in before you can comment on or make changes to this bug.