Memory leak in Firefox 18.x under OS X Mountain Lion (10.8.2)

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: Lonny Eachus, Unassigned)

Tracking

18 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130201065344

Steps to reproduce:

Left Firefox running.


Actual results:

All of my RAM is consumed, and a large amount of hard disk space is also sometimes consumed (virtual memory, no doubt).

Since I installed OS X 10.8 (new, clean install on a new hard drive), and downloaded Firefox 18, it has had a very bad memory leak. If I leave it running for a long time, it will consume all free RAM on my machine, causing other programs to slow to a crawl.

This is most noticeable when I leave it on overnight. Even though the system sleeps, Firefox continues to consume more RAM and virtual memory. Some mornings I have woken up and gone to the computer, and all the RAM is used up and about 20 GB on the hard drive. I have to force quit Firefox before I can get reasonable access anything else.

After quitting Firefox, or force-quitting Firefox, the problem disappears. But even when running Firefox normally during the day, I am sometimes compelled to restart it in order to free up RAM.

This is REALLY bad. I have used Firefox from when it was born out of Netscape. Some older versions of Firefox have had memory issues, but nothing like this.



Expected results:

Nothing. It simply should not be doing this.

I would be tempted to try deleting Firefox and re-installing, but I am concerned about losing my cookies and bookmarks.
Do you use any extensions ?
Please attach the output of about:memory (via the "add an attachment" link) if the memory usage is high.
(Reporter)

Comment 2

5 years ago
Yes, I do use extensions. But they are not new; they are the same extensions I used before I upgraded to OS X 10.8.2. Until then, I had no problems.

I will let it consume a bunch of memory, then dump about:memory for you. I am working so that may take a couple of days.
Please also test without extensions but with luck the about:memory output will already show the issue.
They may be the same extensions as before but we need to narrow down the issue.

Updated

5 years ago
Component: Untriaged → General

Updated

5 years ago
Flags: needinfo?(lonny6)
(Reporter)

Comment 4

5 years ago
I have confirmed that this is due to an add-on. But I have been too busy to narrow it down to just which one caused the problem.
Flags: needinfo?(lonny6)

Updated

5 years ago
Component: General → Extension Compatibility

Comment 5

2 years ago
(In reply to Lonny Eachus from comment #4)
> I have confirmed that this is due to an add-on. But I have been too busy to
> narrow it down to just which one caused the problem.

thanks for the info
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.