Possible leak caused by event listeners in nsLoginManager?

RESOLVED DUPLICATE of bug 839280

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 839280
4 years ago
4 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({mlk})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 years ago
In bug 838711 we found some leaks in Metro Firefox tests, caused by the DOMContentLoaded listener added here but never removed:
http://hg.mozilla.org/projects/elm/rev/cbb24f3d4d11#l1.106

That file is forked from nsLoginManager.js (and split into parent and child scripts, for e10s support).  The original code is here:
http://hg.mozilla.org/mozilla-central/file/325397090d12/toolkit/components/passwordmgr/nsLoginManager.js#l252

At first glance, it looks like the toolkit code might cause a similar leak, though I'm guessing I might be wrong since no leaks are detected in desktop Firefox tests.  Maybe it's different because nsLoginManager is a singleton, while the Metro LoginManagerChild.js is a frame script, loaded once per tab?

Anyway, I'm opening this follow-up bug as a reminder to double-check whether desktop has a similar issue (and if not, to understand why).
See some relevant discussion in bug 839280 comment 14.
(Assignee)

Comment 2

4 years ago
It looks like that bug fixed the leak mentioned here.  I guess I should have investigated this sooner.  :/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839280
You need to log in before you can comment on or make changes to this bug.