Some images have a shadowed border in PDF files

RESOLVED FIXED in Firefox 29

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: mihaelav, Unassigned)

Tracking

Trunk
Firefox 29
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 711207 [details]
screenshot

Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130206 Firefox/21.0

Steps to reproduce:
1. Go to https://notendur.hi.is/hjh/timabundid/rhi_frettir_2012_uppkast_v2.pdf
2. Scroll through the document, focusing on the images

Expected result: Images should display correctly, with no visible borders

Actual result: Some images have a visible shadow-like border

See attached screenshot

Note: reproducible ever since Nightly 14.0a1
(Reporter)

Comment 1

5 years ago
Reproducible also  on the latest Aurora (BuildID: 20130210042017):
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130210 Firefox/20.0
Hardware: x86_64 → All

Updated

5 years ago
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask]

Updated

4 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask] → [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Depends on: 965861
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29

Updated

4 years ago
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.