Auto-advances too soon in fixed-length form entries

VERIFIED DUPLICATE of bug 57700

Status

()

Core
DOM: Events
VERIFIED DUPLICATE of bug 57700
17 years ago
17 years ago

People

(Reporter: Douglas Rohde, Assigned: joki (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-20mdk i686; en-US; rv:0.9)
Gecko/20010523
BuildID:    2001052314

If a form entry box has a fixed length (say 4 chars) it will automatically
advance to the next entry after 3 characters are typed.  It should wait for one
more character.

Reproducible: Always
Steps to Reproduce:
1.Find a web page with an HTML form with fixed length fields with the next-field
specified.
2.Type in the entry.
3.

Actual Results:  It jumps to the next entry too soon.

Expected Results:  Wait until the entry is full.
Is this site, the tabbing code uses:

if (anchorField.value.length + 1 >= anchorFieldLength && !specialChar)

Why is it adding 1 to the length of the value?  That _should_ lead to the 
behavior you're observing, indeed if the code is called after the value is 
updated. Looks like we call the onkeypress handler after updating the value 
while NS 4.x calls it before.  Over to DOM events. This seems broken.
Assignee: rods → joki
Status: UNCONFIRMED → NEW
Component: HTML Form Controls → DOM Events
Ever confirmed: true
(Assignee)

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 57700 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.