Table with OBJECT source not filled

VERIFIED INVALID

Status

()

Core
Layout: Tables
--
major
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Reinout van Schouwen, Assigned: karnaze (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
There are a few bugs in the database concerning the OBJECT tag but I am not sure
this duplicates any of them. 

The above URL is using these tags (I've simplified them a little):

<object classid=... id="bronbestand"
>
<table datasrc="#bronbestand"
>


This is supposed to fill a table but it stays empty. This is true with NS4 also,
but IE does work. What's the problem here?
The problem is that the datasrc attribute is an IE-only thing that nothing but 
IE supports.  Over to HTML tables, recommend invalid.
Assignee: clayton → karnaze
Component: HTML Element → HTMLTables
QA Contact: bsharma → amar

Comment 2

17 years ago
Marking this bug INVALID. Please consult the W3C's HTML 4.01 specification on 
proper use of the OBJECT tag:
http://www.w3.org/TR/1999/REC-html401-19991224/struct/objects.html#h-13.3

<object classid="clsid:333C7BC4-460F-11D0-BC04-0080C7055A83" id="bronbestand" 
width="0" height="0">

Looking closer at your source, by the classid, I was able to look up the name of 
the class your were trying to use by using the Windows Registry tool. It's known 
as the Tabular Data Control, progID: TDCCtl.TDCCtl, or filename: tdc.ocx. Unless 
Microsoft has decided to support our XPCOM model or we start supporting ActiveX, 
this will likely only ever work in Internet Explorer.

You may be able to achive similar, standards compliant, results by manipulating 
the table through the DOM. There's also RDF for remote data sources.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
 This bug is invalid since the HTML used is for "classid" is MS IE specific..
Marking verified 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.