[traceback] Auto generated useranames with old algo cause problems.

VERIFIED DUPLICATE of bug 839138

Status

VERIFIED DUPLICATE of bug 839138
6 years ago
6 years ago

People

(Reporter: giorgos, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Traceback (most recent call last):

  File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/mozillians.org/mozillians/vendor/src/django/django/contrib/auth/decorators.py", line 20, in _wrapped_view
    return view_func(request, *args, **kwargs)

  File "/data/www/mozillians.org/mozillians/apps/phonebook/views.py", line 38, in wrapped
    return f(request, *args, **kwargs)

  File "/data/www/mozillians.org/mozillians/apps/phonebook/views.py", line 198, in search
    return render(request, 'search_ajax.html', d)

  File "/data/www/mozillians.org/mozillians/vendor/src/django/django/shortcuts/__init__.py", line 44, in render
    return HttpResponse(loader.render_to_string(*args, **kwargs),

  File "/data/www/mozillians.org/mozillians/vendor/src/django/django/template/loader.py", line 176, in render_to_string
    return t.render(context_instance)

  File "/data/www/mozillians.org/mozillians/vendor/src/jingo/jingo/__init__.py", line 189, in render
    return super(Template, self).render(context_dict)

  File "/usr/lib64/python2.6/site-packages/jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)

  File "/data/www/mozillians.org/mozillians/templates/search_ajax.html", line 2, in top-level template code
    {{ search_result(person) }}

  File "/data/www/mozillians.org/mozillians/vendor/src/jingo/jingo/__init__.py", line 153, in wrapper
    t = env.get_template(template).render(context)

  File "/data/www/mozillians.org/mozillians/vendor/src/jingo/jingo/__init__.py", line 189, in render
    return super(Template, self).render(context_dict)

  File "/usr/lib64/python2.6/site-packages/jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)

  File "/data/www/mozillians.org/mozillians/apps/phonebook/templates/phonebook/includes/search_result.html", line 2, in top-level template code
    <a class="btn js-btn" href="{{ url('profile', profile.user.username) }}">

  File "/data/www/mozillians.org/mozillians/vendor/src/funfactory/funfactory/helpers.py", line 32, in url
    return reverse(viewname, args=args, kwargs=kwargs)

  File "/data/www/mozillians.org/mozillians/vendor/src/funfactory/funfactory/urlresolvers.py", line 28, in reverse
    url = django_reverse(viewname, urlconf, args, kwargs, prefix)

  File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/urlresolvers.py", line 476, in reverse
    return iri_to_uri(resolver._reverse_with_prefix(view, prefix, *args, **kwargs))

  File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/urlresolvers.py", line 396, in _reverse_with_prefix
    "arguments '%s' not found." % (lookup_view_s, args, kwargs))

NoReverseMatch: Reverse for 'profile' with arguments '(u'336a32bb0bc44ff625b6f0c81bcc5ad843ec610e',)' and keyword arguments '{}' not found.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839138
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.