Open containing folder/Show in Finder are both displayed on Mac OS X

RESOLVED FIXED in Firefox 20

Status

()

Firefox
Downloads Panel
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: alindeac, Assigned: mconley)

Tracking

({regression})

Trunk
Firefox 21
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox20 verified)

Details

Attachments

(1 attachment)

Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130206 Firefox/21.0
Build ID: 20130206031027

Steps to reproduce:
1. Launch Firefox
2. Perform several downloads
3. Open the panel or the downloads view and right click on any completed download
4. While in the panel or in the downloads view focus the right most button.

Expected results:
On Mac OS X the button's tooltip and the option from the context menu are the same.

Actual results:
Same action is done when selecting either Show in Finder option or Open Containing Folder button. To avoid confusion, the option and the button's tooltip should have the same name.
Regression range:

Last good nightly: 2013-01-01
First bad nightly: 2013-01-02

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dec6aa71da64&tochange=a812ef63de87
The issue is also reproducible on the latest Aurora:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20130208 Firefox/20.0
Build ID: 20130208042018
likely bug 746783
Keywords: regression
Created attachment 711925 [details] [diff] [review]
Patch v1

This seems to do the job.
Assignee: nobody → mconley
Status: NEW → ASSIGNED
Comment on attachment 711925 [details] [diff] [review]
Patch v1

Bug 746783 was hiding this bug from us, but didn't introduce it. We never displayed the right strings for the icons.
Attachment #711925 - Flags: review?(mak77)
Comment on attachment 711925 [details] [diff] [review]
Patch v1

Review of attachment 711925 [details] [diff] [review]:
-----------------------------------------------------------------

oops!
Attachment #711925 - Flags: review?(mak77) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/e07057ca9502
https://hg.mozilla.org/mozilla-central/rev/e07057ca9502
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 711925 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): downloads panel feature
User impact if declined: wrong string on Mac
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): minor, ifdef using different string on Mac
String or UUID changes made by this patch: none
Attachment #711925 - Flags: approval-mozilla-aurora?
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20130212 Firefox/21.0
Build ID: 20130212182646

Verified as fixed on the latest hourly tinderbox mozilla central build: - the button's tooltip and the contextual option from the  panel and view is "Show in Finder".
Attachment #711925 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/63a3b373d00e
status-firefox20: --- → fixed
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130220104816

Verified as fixed on Firefox 20 beta 1 - the button's tooltip and the option in the context menu have the same name which is - Show in  Finder.
status-firefox20: fixed → verified
You need to log in before you can comment on or make changes to this bug.