can't view RFC-822 data [message/rfc822] attachment

VERIFIED DUPLICATE of bug 143565

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 143565
17 years ago
13 years ago

People

(Reporter: Leston Buell, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
mozilla1.2beta
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I can't view an RFC-822 data [message/rfc822] e-mail attachment. When i
double-click on the attachment, i get the "downloading" dialogue that wants me
to choose an action for this file. The data should be viewable in Mozilla since
it's just plain text.

I see that there are other RFC-822 bugs in Bugzilla, but none of them seem to
pertain to the ability to view content. 

I'm using build 2001052908 on Linux.
not sure if this is for mscott or ducarroz.

but it sounds related to some stuff that they were discussing recently.
Assignee: sspitzer → ducarroz

Comment 2

17 years ago
when I try to open a .eml attachment in a message, it opens the content in a
stand alone browser window just like 4.x. Is this not what's happening for you? 
(Assignee)

Comment 3

17 years ago
the only difference I see between 6.1 and 4.x is that in 4.x, we display a
nicely formated message while in 6.1 with display the raw data.
(Reporter)

Comment 4

17 years ago
I will have to search for the message i had the trouble with, but it didn't have
an .eml extension. The attachment was identified as [message/rfc822] in the
attachment list box.

As i reported, i couldn't view the attachment at all. Mozilla forced me to save
it and view it in a text editor.

Comment 5

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 4xp

Comment 6

17 years ago
*** Bug 85432 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
I have a similar problem (win2k, 2001100303).  The message displays fine until
it gets to this part in the source:

------=_NextPart_001_0002_01C14BEB.21063FE0
Content-Type: message/rfc822; name="what a difference a day makes.email"
Content-Disposition: attachment; filename="what a difference a day makes.email"
Content-Transfer-Encoding: quoted-printable

and then it doesn't show the attached email - not even as raw plain text.  This
is within IMAP viewing, but also if I drag the mail.eml file onto mozilla, I get
the same view.
(Assignee)

Comment 8

16 years ago
Still not working properly! When I open, direclty from the mail display window,
an rfc822 attachment, a new brower window open but the message is displayed as raw!
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0

Comment 9

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 10

16 years ago
Can we get this bug a Mozilla 1.0 keyword?  I can't imagine Mozilla (or any
other email application for that matter) being considered (feature) complete if
it can't properly display RFC-822 data properly!

Updated

16 years ago
QA Contact: esther → trix

Comment 11

16 years ago
I just tried the following with 1.1R under Win 2000:

- received a message with a message/rfc822 attachment
- opened the message/rfc822 attachment

To my surprise, MozMail opened a web browser window with the raw contents of the
attachment in it.

I expected, as would every other user, MozMail to simply open the attachment as
a message window.

I notice that this is marked as for the Linux OS and the target milestone has
slipped behind.  Perhaps these should be updated (not to mention someone fixing
the bug).

Comment 12

16 years ago
Shouldn't this have the dataloss keyword - if you can't see it, sounds like lost
data to me!  Hopefully that would also get it back on the radar for 1.2.

BTW, where is the right place to nominate bugs for 1.2 (or others if it doesn't
make it by then)?
(Assignee)

Comment 13

15 years ago
We have another open bug about opening the attachment into a mail display window
instead of a browser window...

*** This bug has been marked as a duplicate of 143565 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Target Milestone: mozilla1.0.1 → mozilla1.2beta

Comment 14

15 years ago
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.