Pressing Enter in autocomplete menu should load that URL in Open Web Location dialog

VERIFIED FIXED

Status

SeaMonkey
Autocomplete
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Joseph Wang, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.5-1mdk i586; en-US; rv:0.9+)
Gecko/20010603
BuildID:    2001060306

URL name completion under the "Open Web Location" is a nice
new feature but one with a counter intuitive UI

The sequence of events is

1. I type in a partial URL
2. The combo box drops down with a list of URLS to complete
3. I move the arrow keys to select one of the URLS
4. Press return
5. The URL then gets put into the input box and I have to 
do something more to have it load the page

It would be a lot nicer if that first return loaded the page
rather than just put the URL in the dialog box

Reproducible: Always
Steps to Reproduce:
1.See above
2.
3.
ccing hewitt -- it's his widget

Comment 2

17 years ago
I'm probably opposed to this rfe...
sometimes people want to add to a url from autocomplete, eg, http://bo 
completing to http://bonsai.mozilla.org/ and I want to add 
c(vsblame.cgi?file=)+ctrl-v for some random file.
Severity: normal → enhancement

Comment 3

17 years ago
With build 2001062105 on Mac OS 9.1, I don't get an auto-completion menu at all.
Is there a separate bug for that?
Keywords: qawanted

Comment 4

17 years ago
marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Pressing enter after choosing URL completion should load page → [RFE] Pressing enter after choosing URL completion should load page

Comment 5

17 years ago
Worksforme, build 2001082104, Mac OS 9.1. If this is still happening on Linux, 
it's a bug. --> XP Apps: GUI for verification.
Assignee: mpt → blakeross
Severity: enhancement → normal
Component: User Interface Design → XP Apps: GUI Features
QA Contact: zach → sairuh
Summary: [RFE] Pressing enter after choosing URL completion should load page → Pressing Enter in autocomplete menu should load that URL
wfm, 2001.08.22.08-comm bits on linux.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Component: XP Apps: GUI Features → XP Apps: Autocomplete
Resolution: --- → WORKSFORME
oh, wait a sec --this wfm when i'm in the URLbar. i didn't initially read this
properly: the problem is with the textfield in the Open Web Location dialog. in
which case, yes, hitting Enter doesn't automatically dismiss the dialog and load
the page after selecting the url from the autocomplete list.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
so, i'm still assuming this is an issue with the field in the Open Web Location
dialog, not the URL bar --right? [btw, i see this on all platforms,
2001.08.27-comm.]

this is what i'm doing:

1. bring Open Web Location dialog [shift+accel+L, or File > Open Web Location].
2. in the textfield, start typing a url you've viewed --the autocomplete
droplist should appear.
3. arrow down the droplist to select [highlight] a url.
4. hit the enter key.

expected(*): at step (4), the dialog is dismissed and the url selected in step
(3) is loaded in the browser.

actual: at step (4), the selection appears in the dialog's textfield. however,
the dialog remains up and the page doesn't load until you hit enter again.

(*) the question is, is this really expected or a bug in the behavior of the
selection within the droplist of this dialog?
Keywords: qawanted
Summary: Pressing Enter in autocomplete menu should load that URL → Pressing Enter in autocomplete menu should load that URL in Open Web Location dialog

Comment 9

17 years ago
The auto-complete menu in the dialog should behave the same way as the
auto-complete menu in the browser window.
(Assignee)

Comment 10

17 years ago
Fixed.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

17 years ago
*** Bug 100805 has been marked as a duplicate of this bug. ***
vrfy fixed with the following commercial verif bits:

linux [rh6.2] - 2001.11.01.12
winnt - 2001.10.31.03
mac 10.1 - 2001.10.31.13
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.