Closed Bug 839256 Opened 7 years ago Closed 7 years ago

crash in mozilla::dom::TabChild::CachedFileDescriptorCallbackRunnable::~CachedFileDescriptorCallbackRunnable after trying to update Here maps

Categories

(Firefox OS Graveyard :: Gaia::System, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: nhirata, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [b2g-crash])

Crash Data

Attachments

(2 files)

Attached file log cat
This bug was filed from the Socorro interface and is 
report bp-8c80893b-60d4-4383-89e7-954d82130207 .
============================================================= 
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4518b78583d0
Gaia   7e54ca673277b20b1d91d18477dc44d6ad226761
BuildID 20130207070202
Version 18.0
Unagi

## Repro :
1. flash device
2. go through fte, set up wifi
3. go to settings, device info, select check now
4. pull down notification bar
5. update HERE

## Expected :
No crash

## Actual :
Crash occurs

## Note :
blocking-b2g: --- → leo?
Hardware: All → ARM
Summary: crash in jemalloc_crash after trying to update Here maps. → crash in mozilla::dom::TabChild::CachedFileDescriptorCallbackRunnable::~CachedFileDescriptorCallbackRunnable after trying to update Here maps
I wonder if https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Adom%3A%3ATabChild%3A%3ACachedFileDescriptorCallbackRunnable%3A%3ARun is the same issue, the signature is almost identical, just that it's ::Run instead of the destructor.
Naoki: Isn't there a bug on file for the fact that we are offering a Maps update when there isn't one? That may be the reason why we are crashing. That bug had to do with a missing etag.
"Missing ETag sounds" like a server-side thing. We shouldn't crash on the client-side because of a server-side bug.
I was able to reproduce this crash without any update operation using today's build: https://crash-stats.mozilla.com/report/index/cc8022e0-2991-45e8-bd02-96d722130208
Marcia I believe you are talking about : bug 834903
there is also Bug 832565 

Neither talk about crashing.  I agree with Kairo.  We shouldn't be crashing and we should gracefully handle these situations.  Neither bug talks about crashing.
(Need more coffee... maybe I won't repeat myself so often... )
This trivially reproduces just launching the maps app.

Has the cause of this been backed out?
Flags: needinfo?(bent.mozilla)
$ (cd gecko/ && git rev-parse HEAD && cd ../gaia && git rev-parse HEAD)
cb007bcbaaffacf2e8ea93a60cf7c4ccd1164437
9aab784d8e572853c79403334f4dac0f9c9c4678
Looks like bug 835698 relanded.

bent, this crash is still reproducing, can you please fix or back out?

/me starts backout timer ;)
Blocks: 835698
Wait, still? This is crazy. Both jduell and I ran this a ton on our local builds. How is it we have no automated tests that show crashes in this code?

I'm on vacation until Thursday with sort of restricted access to internet (bugmail is about the max this crappy connection can do... I can't get an hg pull to succeed even) so if you need to back me out please do (with my apologies).
Flags: needinfo?(bent.mozilla)
Alright, need to back out then :(.
Any debugging help would be greatly appreciated (since I've never seen this...)!
Issue occurs on:

build: 20130213071150
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6fec2938ac1e
Gaia   07aa79239ced90a7ca0e8da8829fbcb330c42e9f
(In reply to Allen Maxwell from comment #14)
> Issue occurs on:
> 
> build: 20130213071150
> Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6fec2938ac1e

Are you sure about the gecko revision?  It's from after bug 835698 was backed out again.
I can't seem to reproduce this with the following steps, at least:

1) put |export B2G_UPDATE_CHANNEL=none| in .userconfig and reconfig/build
 -- this is to prevent having to take OS update along with maps update

2) flash

3) boot, wait a minute until "1 update avail" shows in pull-down.  Select it.

Update works for me fine (AFAICT: I don't see a way to check version # of app.  There's no crash at least).   I can also launch maps app fine, either before or after doing the update.

This is on Unagi phone using debug build of b2g18 with the lastest backout of this bug reapplied.
Crashes stopped after 18.0/20130208070201.
Scoobi is right.

Most of the recent crashes have to do with using an older version of the kernel (date on the OS should be Dec. 5th) and having an older build.  We need people on the latest stuff to verify that it's fixed for sure.
I just relanded bug 835698, let's see if this comes back.
(If it does, let's file a new bug.)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
blocking-b2g: leo? → ---
You need to log in before you can comment on or make changes to this bug.