Notification appearing after setting keyword.URL to "http://www.google.com" or "http://www.search.google.com"

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: Manuela Muntean [Away], Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Reproducible on the latest Beta (BuildID: 20130206083616): Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

Reproducible on the latest Aurora (BuildID: 20130207042017): Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20130207 Firefox/20.0

Reproducible on the latest Nightly (BuildID: 20130207030936): Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130207 Firefox/21.0

Steps to reproduce:

1. Launch Firefox. 
2. Go to about:config, type keyword.URL in the search bar and hit Enter.
3. Double click on this preference, and type in the edit box: http://www.google.com or http://www.search.google.com. Click OK.
4. Open a new tab, type in the awesomebar one or more words to search for, and hit Enter.

Expected results: No notification should appear.

Actual results: A notification appears under the awesomebar: Firefox is using 'google.com' for searches from the location bar. Would you like to restore the default search (Google)?

Note:
1. This issue is not a regression: it reproduces back to Nightly 19.0a1, BuildID: 20121107045842.
(Reporter)

Updated

5 years ago
Blocks: 718088
OS: Windows 7 → All
Hardware: x86_64 → All
(Reporter)

Updated

5 years ago
Version: unspecified → Trunk
(In reply to Manuela Muntean [:Manuela] [QA] from comment #0)
> Actual results: A notification appears under the awesomebar: Firefox is
> using 'google.com' for searches from the location bar. Would you like to
> restore the default search (Google)?

This is not what I see; assuming the search terms you enter are "search terms", I see:

"Firefox is using 'google.comsearch+terms' for searches from the location bar. Would you like to restore the default search (Google)?"

Is that what you see as well? If so, then this is a similar case as bug 839416 - "http://google.com" without a trailing slash is an invalid keyword.URL value. If you add a slash to the end, you should get the expected behavior (no notification since the hosts match).
(Reporter)

Comment 2

5 years ago
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #1)
> (In reply to Manuela Muntean [:Manuela] [QA] from comment #0)
> > Actual results: A notification appears under the awesomebar: Firefox is
> > using 'google.com' for searches from the location bar. Would you like to
> > restore the default search (Google)?
> 
> This is not what I see; assuming the search terms you enter are "search
> terms", I see:
> 
> "Firefox is using 'google.comsearch+terms' for searches from the location
> bar. Would you like to restore the default search (Google)?"
> 
> Is that what you see as well? If so, then this is a similar case as bug
> 839416 - "http://google.com" without a trailing slash is an invalid
> keyword.URL value. If you add a slash to the end, you should get the
> expected behavior (no notification since the hosts match).

Gavin, indeed, this is what I see as well. 

If I set the pref to "http://www.search.google.com/" and type "search terms" in the awesomebar, I get a server not found error. (without the notification)

If I set the pref to "http://www.google.com/" and type "search terms" in the awesomebar, I get an Error 404 page not found, in a webpage with the Google logo in it. (without the notification)
(Reporter)

Comment 3

5 years ago
(In reply to Manuela Muntean [:Manuela] [QA] from comment #2)
> (In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment
> #1)
> > (In reply to Manuela Muntean [:Manuela] [QA] from comment #0)
> > > Actual results: A notification appears under the awesomebar: Firefox is
> > > using 'google.com' for searches from the location bar. Would you like to
> > > restore the default search (Google)?
> > 
> > This is not what I see; assuming the search terms you enter are "search
> > terms", I see:
> > 
> > "Firefox is using 'google.comsearch+terms' for searches from the location
> > bar. Would you like to restore the default search (Google)?"
> > 
> > Is that what you see as well? If so, then this is a similar case as bug
> > 839416 - "http://google.com" without a trailing slash is an invalid
> > keyword.URL value. If you add a slash to the end, you should get the
> > expected behavior (no notification since the hosts match).
> 
> Gavin, indeed, this is what I see as well. 
> 
> If I set the pref to "http://www.search.google.com/" and type "search terms"
> in the awesomebar, I get a server not found error. (without the notification)
> 
> If I set the pref to "http://www.google.com/" and type "search terms" in the
> awesomebar, I get an Error 404 page not found, in a webpage with the Google
> logo in it. (without the notification)

I get this behavior both on a Windows 7 64-bit machine and a Mac OSX 10.8 one, with Firefox 19 beta 5.
Wontfix for the same reasons as bug 839416.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.