Last Comment Bug 839413 - Port bug 830594 - Turn on ENABLE_SHARED_JS on Win64 builder for PGO linker limit
: Port bug 830594 - Turn on ENABLE_SHARED_JS on Win64 builder for PGO linker limit
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Windows 8
: -- normal (vote)
: Thunderbird 21.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
Depends on: 830594
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 00:26 PST by Mark Banner (:standard8)
Modified: 2013-02-08 05:18 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
The fix (497 bytes, patch)
2013-02-08 00:38 PST, Mark Banner (:standard8)
bugspam.Callek: review+
Details | Diff | Review

Description Mark Banner (:standard8) 2013-02-08 00:26:04 PST
+++ This bug was initially created as a clone of Bug #830594 +++

I turned off ENABLE_SHARED_JS on Bin64 builder by bug 633465.  Actually, Win64 builder uses 32-bit linker due to https://connect.microsoft.com/VisualStudio/feedback/details/686117, but PGO linker seems to be 4GB limit. So nightly and pgo build cannot be built on builtbot due to ICE.
Comment 1 Mark Banner (:standard8) 2013-02-08 00:38:00 PST
Created attachment 711732 [details] [diff] [review]
The fix

We need this to un-bust our Win64 bit builds - where I think the bustage is caused by the now different default setting of ENABLE_SHARED_JS.
Comment 2 Justin Wood (:Callek) 2013-02-08 00:54:31 PST
Comment on attachment 711732 [details] [diff] [review]
The fix

assuming this patch is against c-c not m-c, rs+=me, Win64 is (imho) also unsupported, so I don't care to think on this long, so long as it also doesn't break other builds (which this wont)

If its a m-c patch, please treat my rs+ as f+ and get a real peer to review.
Comment 3 Mark Banner (:standard8) 2013-02-08 05:18:43 PST
https://hg.mozilla.org/comm-central/rev/a9077e1863b5

Note You need to log in before you can comment on or make changes to this bug.