suppress "untracked file" warnings about icc.json

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

unspecified

Firefox Tracking Flags

(b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 711880 [details] [diff] [review]
patch v1: add icc.json to .gitignore

build/applications-data.js generates apps/settings/resources/icc.json, so .gitignore should ignore it to suppress spurious "untracked files" warnings by Git after building Gaia:

  02-08 09:45 > git status
  # On branch master
  # Untracked files:
  #   (use "git add <file>..." to include in what will be committed)
  #
  #	apps/settings/resources/icc.json
  nothing added to commit but untracked files present (use "git add" to track)


https://github.com/mozilla-b2g/gaia/pull/8028
Attachment #711880 - Flags: review?(fabrice)
Attachment #711880 - Flags: review?(fabrice) → review+
(Assignee)

Comment 1

5 years ago
Fabrice: can you merge the pull request?

https://github.com/mozilla-b2g/gaia/pull/8028
(Assignee)

Comment 2

5 years ago
Thanks Fabrice!

https://github.com/mozilla-b2g/gaia/commit/165e41522ce8c781496dce0c0e93bf5ebd5b58ad
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

5 years ago
Comment on attachment 711880 [details] [diff] [review]
patch v1: add icc.json to .gitignore

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): no apparent bug number, but this is the commit that caused the regression: https://github.com/mozilla-b2g/gaia/commit/8558d793b732fa5a90df10f8429e3eb67e6c5008
User impact if declined: no user impact, but developers will see an unwelcome and distracting message when performing certain Git operations.
Testing completed: after making change, built Gaia and verified that Git ignores file.
Risk to taking this patch (and alternatives if risky): this is about as low-risk as it's possible for a change to be; there are no alternatives.
Attachment #711880 - Flags: approval-gaia-v1?

Comment 4

5 years ago
Comment on attachment 711880 [details] [diff] [review]
patch v1: add icc.json to .gitignore

No user impact either way, so we can approve.
Attachment #711880 - Flags: approval-gaia-v1? → approval-gaia-v1+
(Assignee)

Comment 5

5 years ago
@fabrice: Can you merge the pull request for the v1-train branch?

https://github.com/mozilla-b2g/gaia/pull/8046
(In reply to Myk Melez [:myk] [@mykmelez] from comment #5)
> @fabrice: Can you merge the pull request for the v1-train branch?
> 
> https://github.com/mozilla-b2g/gaia/pull/8046

jhford might be able to help here as well.
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
v1-train: 9aab784d8e572853c79403334f4dac0f9c9c4678
status-b2g18: affected → fixed
Batch edit: bugs fixed on b2g18 since 1/25 branch of v1.0 are fixed on v1.0.1
status-b2g18-v1.0.1: wontfix → fixed
You need to log in before you can comment on or make changes to this bug.