[traceback] Internal Server Error: /mozpay/

RESOLVED WONTFIX

Status

Marketplace
Payments/Refunds
P1
blocker
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: krupa, Unassigned)

Tracking

2013-02-14
Points:
---

Details

(Whiteboard: p=)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Click on the purchase button for Private Yacht

sentry: http://sentry.dmz.phx1.mozilla.com/marketplace-dev-webpay/group/10921/

Internal Server Error: /mozpay/

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "django/views/decorators/http.py", line 41, in inner
    return func(request, *args, **kwargs)
  File "webpay/pay/views.py", line 102, in lobby
    res = process_pay_req(request)
  File "webpay/pay/views.py", line 93, in process_pay_req
    request.session['notes'])
  File "celery/app/task/__init__.py", line 371, in delay
    return self.apply_async(args, kwargs)
  File "nuggets/celeryutils.py", line 22, in apply_async
    return super(Task, self).apply_async(args, kwargs, **options)
  File "celery/app/task/__init__.py", line 463, in apply_async
    return self.apply(args, kwargs, task_id=task_id, **options)
  File "celery/app/task/__init__.py", line 616, in apply
    request=request, propagate=throw)
  File "celery/execute/trace.py", line 220, in eager_trace_task
    uuid, args, kwargs, request)
  File "celery/execute/trace.py", line 153, in trace_task
    R = retval = task(*args, **kwargs)
  File "nuggets/celeryutils.py", line 35, in wrapped
    return fun(*args, **kw)
  File "multidb/pinning.py", line 46, in decorator
    return func(*args, **kw)
  File "multidb/pinning.py", line 46, in decorator
    return func(*args, **kw)
  File "django/db/transaction.py", line 209, in inner
    return func(*args, **kwargs)
  File "webpay/pay/tasks.py", line 103, in start_pay
    prices['prices']
  File "lib/solitude/api.py", line 203, in configure_product_for_billing
    'redirect_url_onerror': redirect_url_onerror,
  File "slumber/__init__.py", line 139, in post
    resp = self._request("POST", data=s.dumps(data), params=kwargs)
  File "slumber/__init__.py", line 103, in _request
    raise exceptions.HttpServerError("Server Error %s: %s" % (resp.status_code, url), response=resp, content=resp.content)
I can't reproduce: https://marketplace-dev.allizom.org/mozpay/

This was probably from when GitHub was down.
(Reporter)

Updated

6 years ago
Priority: -- → P1
Whiteboard: p=
All of the existing apps need to be resubmitted because Bango changed some data in their database. There is an email with details about it. If you submit a new app to test payments with then it should work.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.