When restarting a download for a packaged app, the app icon occasionally can be selected again to start the download again, causing odd progress bar behavior

RESOLVED DUPLICATE of bug 830463

Status

Core Graveyard
DOM: Apps
RESOLVED DUPLICATE of bug 830463
5 years ago
2 months ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Build: B2G 18 2/8/2013
Device: Unagi

Steps:

1. Start download of a large packaged app
2. Cancel download
3. Select the icon to restart the download
4. While it's downloading, select the icon again
5. If #4 fails to show the restart download prompt, repeat step 2 - 4

Expected:

step #4 should never show the restart download prompt as a result.

Actual:

Occasionally, the restart download prompt appears. Selecting to download puts the download of the app into an odd state - you'll see the progress bars for the downloading of app jump back and forth between two download states.
(Reporter)

Updated

5 years ago
Blocks: 802574
(Reporter)

Comment 1

5 years ago
Very similar behavior seen with hosted app with appcache. Not sure if it's the same bug.
Did you have the fix to Bug 838561 in your build as well ?
(note: because we're afraid of regressions, Bug 838561 was not approved for v1.0 though. Which I regret because it would guard against these things.)
(Reporter)

Comment 3

5 years ago
(In reply to Julien Wajsberg [:julienw] from comment #2)
> Did you have the fix to Bug 838561 in your build as well ?
> (note: because we're afraid of regressions, Bug 838561 was not approved for
> v1.0 though. Which I regret because it would guard against these things.)

I don't think so. Here's an idea - all of these patches are now on central. So on Monday, I'll flash a central build and try some of these patches out.
I provided a fix for Bug 830463. With this fix, we send a progress event asap and therefore we should _never_ have the restart download prompt in step 4.

I'm quite sure that's the bug you're seeing here, and that we should dupe to Bug 830463.

Worked on sunday so that you could test this as soon as possible ;)
(Reporter)

Comment 5

5 years ago
Okay. I'll dup then.

When that patch lands on central, I'll test it out to see if it's resolving what I'm seeing.
No longer blocks: 802574
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 830463

Updated

2 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.