Closed Bug 839744 Opened 12 years ago Closed 11 years ago

cant close alert box if mouse is dragging text

Categories

(Core :: DOM: Events, defect)

21 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 100180

People

(Reporter: mayankleoboy1, Unassigned)

Details

(Keywords: testcase)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130208 Firefox/21.0
Build ID: 20130208031053

Steps to reproduce:

1. start fresh profile.
2. Install ad block plus.
3. Go to https://www.google.co.in/search?num=50&hl=en&newwindow=1&tbo=d&q=ngohq&oq=ngohq&gs_l=serp.3..0i10j0l2j0i10l2j0l5.73194.74537.0.74635.5.5.0.0.0.0.199.732.0j4.4.0.les%3B..0.0...1c.1.2.serp.FX1uGUJ6LHg

4. ctrl+click on the first link, to open it in the background tab. (NGOHQ.com)
5. Very quickly, select some text on the google page and drag it a bit. Hole the drag position.
6. After a few seconds a alert box will appear on the Ngohq site, and that tab will come in the foreground.



Actual results:

you cant close the alert box. Because the mouse pointer is unusable.


Expected results:

if a alert box appears in a different tab than the first, then the dragged text should be released.
a simpler test case would be a page that displays a alert message after 5 seconds it has loaded.

Note that to close the alert box, only the "esc" key can be used.
Component: Untriaged → DOM: Events
Product: Firefox → Core
It's really a bad interaction for the user. Only ESC is working, the main UI thread is blocked;if FF is minimized, it can't be reopen and the text dragging by the mouse is painted over the OS desktop.
Attached file Reduced testcase
STR:
1) Open a random website
2) Open the testcase in a 2nd tab
3) Go back to the 1st tab (in less 5 sec)
4) Select some text and drag it
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: