Sentences should be capitalized

RESOLVED WORKSFORME

Status

()

Firefox for Android
Keyboards and IME
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: pretzer, Unassigned)

Tracking

Trunk
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
When typing into a text field, sentences should be automatically capitalized, that means the keyboard should switch to capital letters for the first letter overall and after each full stop for one letter. 
For example when I type into the comment of a Bugzilla bug without using the shift key in Chrome I get this: 
"Hello. Firefox is awesome."
While in Firefox I get this:
"hello. firefox is awesome."

The standard inputType for Android text fields would be "textCapSentences", but I'm not sure if that's applicable to our implementation. 

I'm using SwiftKey, but I guess it's independent of the IME.
Created attachment 712557 [details]
inputmode-test.html

I confirmed that Chrome Beta and JB stock browser automatically capitalize <textarea> text, while Gecko does not.

In the attached test case, Chrome and the stock browser capitalize the <textarea>, but none of the other text inputs. Gecko capitalizes the (non-standard) `inputmode="autocapitalize"` text input, but none of the others.

We should probably autocapitalize <textarea> text, too.
GeckoInputConnection.java defaults to lowercase text here:

https://hg.mozilla.org/mozilla-central/annotate/tip/mobile/android/base/GeckoInputConnection.java#l430

Is there a way our Java code can determine that the text input is a <textarea>? Or would Gecko core code need to pass that info from C++ to Java?
(In reply to Chris Peterson (:cpeterson) from comment #2)
> GeckoInputConnection.java defaults to lowercase text here:
> 
> https://hg.mozilla.org/mozilla-central/annotate/tip/mobile/android/base/
> GeckoInputConnection.java#l430
> 
> Is there a way our Java code can determine that the text input is a
> <textarea>? Or would Gecko core code need to pass that info from C++ to Java?

AFAIK Gecko needs to pass it in (I assume not just for textarea but also for contentEditable/designMode) . This could also be useful for setting InputType. TYPE_TEXT_FLAG_MULTI_LINE, which we do not set currently.
(Reporter)

Comment 4

5 years ago
I noticed that my sentences do get capitalized in Nightly now, but that seems to be a recent enhancement by SwiftKey. When I use the stock VKB my sentences still do not get capitalized.
Therefore this bug should still be kept open, right?
(Reporter)

Comment 5

4 years ago
This was fixed by bug 871884
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.