Closed Bug 839782 Opened 7 years ago Closed 4 years ago

Homescreen crashes when app is installed via remote debugger

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: timo, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [b2g-crash])

User Agent: Opera/9.80 (X11; Linux x86_64; Edition Linux Mint) Presto/2.12.388 Version/12.14

Steps to reproduce:

Today I updated my unagi using the latest ota update. After the restart, I installed a privileged app via the remote debugger. It didn't show up on the home screen, but was listed in the settings.
I restarted the device and the app showed up. I then removed it and installed a new version of the app.


Actual results:

The homescreen showed the name of the app for half a second and then just crashed.
After that, the homescreen was restarted and the app showed up like normal.


Expected results:

The app should have been installed without a crash of the homescreen.
Severity: normal → major
Keywords: crash
Whiteboard: [b2g-crash]
Component: General → Gaia::Homescreen
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.